Dragging an address (bookmark icon) from the location bar to a folder in personal toolbar captures focus forever under linux (drag and n drop, DnD)

VERIFIED DUPLICATE of bug 96504

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED DUPLICATE of bug 96504
16 years ago
14 years ago

People

(Reporter: Mikko Rantalainen, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

When you have some folders in the personal toolbar and you try to drag address
from location bar to a folder inside toolbar causes the target folder to open,
the drag icon gets stucked over the folder "button" and focus gets stucked in
the menu but you can't drop the link anywhere or close the menu.

Reproducible: Always
Steps to Reproduce:
1. Make sure personal toolbar is visible
2. Make a new folder inside personal toolbar
3. Drag the current location to this new folder

Actual Results:  Folder opens, drag icon halts and you cannot close folder
inside the personal toolbar.

Expected Results:  Bookmark should be stored inside the newly created folder and
folder should close itself.

Focus isn't stucked totally. I'm able to change between tabs by tripple clicking
the tabs (double clicking fast enough could be enough). After tripple clicking
File-menu and succesfully opening it Mozilla works otherwise normally but the
folder inside personal toolbar stays open. If I click in the still open folder
in the personal toolbar the focus gets stucked again.

Mozilla is somehow successfully capturing even keyboard events that normally go
to window manager only. I'm seeing this problem with Linux only, a version under
Win98se on the same computer works fine. The linux distribution I'm using is
Mandrake 8.2/x86.

Perhaps this should be have critical severity because it first seems that full
UI crashed. However, if user doesn't kill the process no dataloss is happening.
This might have some relation to bug 109237.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 96504 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.