Closed Bug 1403566 Opened 7 years ago Closed 6 years ago

Web Apps - Login auto-complete isn't working, with multiple logins saved

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P2)

58 Branch
ARM
Android
defect

Tracking

(fennec+, firefox57 disabled, firefox58 wontfix, firefox59 verified)

RESOLVED FIXED
Firefox 59
Tracking Status
fennec + ---
firefox57 --- disabled
firefox58 --- wontfix
firefox59 --- verified

People

(Reporter: ohorvath, Assigned: cnevinchen)

References

Details

(Whiteboard: [pwa-front-end][FNC][SPT59.2][INT])

Attachments

(1 file)

Devices: 
LG G4 (Android 6);
Build: Nightly 58.0a1 (2017-09-26);

Steps to reproduce:
1. Go to twitter.com web app and log in.
2. Save the password.
3. Log out and go back to the login page.
4. Tap the username field for autocomplete options.

Expected result:
Username & password should be auto-filled in if it was saved. If there are multiple logins saved, a drop-down should display the options.

Actual result:
- when there is just one login saved, the autocomplete works: username and pass are auto-filled in when you start the web app.
- when there are 2 or more logins saved for the same site, passwords are filled in but usernames not. You have to type in the username and then the password will be autocompleted. In the browser, there is a username drop-down list for auto-complete that doesn't appear in the web app.

note: The same issue occurs for custom tabs if you open the twitter login page(from a gmail link, for e.g.).
Jim is everything in for this to work?
Flags: needinfo?(nchen)
We need a FormAssistPopup view in the WebAppActivity layout, which is currently just the GeckoView itself [1]. So basically, we need to add some kind of relative layout for WebAppActivity, and add [2] to that.

Nevin, can someone from frontend work on this?

[1] http://searchfox.org/mozilla-central/rev/3dbb47302e114219c53e99ebaf50c5cb727358ab/mobile/android/base/java/org/mozilla/gecko/webapps/WebAppActivity.java#116
[2] http://searchfox.org/mozilla-central/rev/3dbb47302e114219c53e99ebaf50c5cb727358ab/mobile/android/app/src/main/res/layout/customtabs_activity.xml#30
Flags: needinfo?(nchen) → needinfo?(cnevinchen)
Hi Wesly, Joe
Please help prioritze this for FormAssistPopup support for PWA(GeckoView-based app)
Flags: needinfo?(wehuang)
Flags: needinfo?(jcheng)
Flags: needinfo?(cnevinchen)
is this part of the GeckoView feature offering?
Flags: needinfo?(jcheng) → needinfo?(snorp)
Flags: needinfo?(wehuang)
Whiteboard: [pwa-front-end]
Priority: -- → P2
P2 for now, since same as Custom Tab that's already in 57, per comment 0.
tracking-fennec: ? → +
(In reply to Joe Cheng [:jcheng] (please needinfo) from comment #4)
> is this part of the GeckoView feature offering?

No, but there is some stuff to make it work in Custom Tabs. Comment #2 lists the steps the frontend needs to take to make it work in the PWA activity.
Flags: needinfo?(snorp)
Comment on attachment 8932381 [details]
Bug 1403566 - Support mutli login for PWA.

https://reviewboard.mozilla.org/r/203442/#review208984
Attachment #8932381 - Flags: review?(nchen) → review+
Assignee: nobody → cnevinchen
Pushed by nechen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5f945ce89be8
Support mutli login for PWA. r=jchen
https://hg.mozilla.org/mozilla-central/rev/5f945ce89be8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Does this need a Beta uplift request?
Flags: needinfo?(cnevinchen)
Hi Wesly. Can we have QA verified first before we uplift? Or should we?
Flags: needinfo?(cnevinchen) → needinfo?(wehuang)
Oana, Nevin had a patch to fix this one during some other tech. discussion. Would you help on the verification before we uplift it to Beta? Thanks!
Flags: needinfo?(wehuang) → needinfo?(oana.horvath)
Verified as fixed on Nightly 59 (2017-12-05) for PWA and custom tabs.
Devices:
Samsung Galaxy Note 4 (Android 5.0.1)
LG Nexus 5 (Android 6.0.1)
Flags: needinfo?(oana.horvath)
Whiteboard: [pwa-front-end] → [pwa-front-end][FNC][SPT59.2][INT]
Comment on attachment 8932381 [details]
Bug 1403566 - Support mutli login for PWA.

Approval Request Comment
[Feature/Bug causing the regression]:PWA needs to display a list in Java UI when users have multiple login saved
[User impact if declined]: User won't see anything if they have more than one login saved
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]:  no
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: We just show extra UI. So it should be safe.
[String changes made/needed]: no
Attachment #8932381 - Flags: approval-mozilla-beta?
I'm not sure I'm comfortable with "we just show extra UI" as risk assessment here.  We've had this bug on file for two months and it hasn't been a priority until now, why is it suddenly needed in late beta?
Flags: needinfo?(cnevinchen)
Just found out my reply is not saved! I thought I replied just after you posted ... sorry again.


(In reply to Julien Cristau [:jcristau] from comment #16)
> I'm not sure I'm comfortable with "we just show extra UI" as risk assessment
The reason I said it "just show extra UI" is because the same UI is displayed for custom tab (see comment 2) so it's nothing new.

> here.  We've had this bug on file for two months and it hasn't been a
> priority until now, why is it suddenly needed in late beta?

This is because we don't have the time and there's no plan to fix p2.(see  Comment 5)

> why is it suddenly needed in late beta? Cause 

We fix it now cuase we finaly have time for bugs other than p2 (see https://wiki.mozilla.org/Mobile/Firefox_for_Android, sprint 59.2)

I think Wesly can help elaberate more
Flags: needinfo?(wehuang)
Flags: needinfo?(jcristau)
Flags: needinfo?(cnevinchen)
Comment on attachment 8932381 [details]
Bug 1403566 - Support mutli login for PWA.

It's late beta. Might be a big risky to have this in beta. Beta58-.
Attachment #8932381 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Flags: needinfo?(jcristau)
(In reply to Nevin Chen [:nechen](pto till Jan 3rd) from comment #18)
> (In reply to Julien Cristau [:jcristau] from comment #16)
> > why is it suddenly needed in late beta? Cause  
> We fix it now cuase we finaly have time for bugs other than p2 (see
> https://wiki.mozilla.org/Mobile/Firefox_for_Android, sprint 59.2)
> 
> I think Wesly can help elaberate more

Sorry for late. Indeed we plan to tackle this issue later so we didn't fix it in the 1st place. I can understand RM's concern as well, so let's live with it.
Flags: needinfo?(wehuang)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.