Closed Bug 1403878 Opened 2 years ago Closed 2 years ago

Hide toolbars does not work if URL bar was focused when toggling fullscreen mode

Categories

(Firefox :: Toolbars and Customization, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1195927
Tracking Status
firefox55 --- unaffected
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- fix-optional
firefox59 --- fix-optional

People

(Reporter: mozilla, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, regressionwindow-wanted)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170926220106

Steps to reproduce:

Launch firefox, with fresh profile.  Upon startup, the URL bar should have focus.  Press F11 to toggle fullscreen mode.


Actual results:

Window goes fullscreen, but toolbars stay visible despite "hide toolbars" being checked (per default).  It makes sense since the URL bar is still in focus.  But if you enter an URL, or manually defocus the bar, or otherwise navigate to some page, the toolbars will just stay there, despite being no longer needed.  The only way I can think of to make "hide toolbars" actually work is to toggle fullscreen mode off, defocus the URL bar, and then toggle it back on again.


Expected results:

Toolbar hiding ought to work whether the URL bar is focused or not when fullscreen mode is toggled.
Hiding works OK in 52ESR and 55.  It seems glitchy in beta 57.0b3 (20170925150345) and in nightly build (build id above).
Component: Untriaged → Toolbars and Customization
This seems like a regression of bug 1192683. Can you find an accurate regression window?
Blocks: 1208939
Depends on: 1192683
Flags: needinfo?(mozilla)
Priority: -- → P3
See Also: → 1226385
Well, things got complicated.  The run of mozregression landed me on a very unlikely window:

14:19.44 INFO: Last good revision: 2a63a6c35033b5cbc6c98cabc7657c7290284691
14:19.44 INFO: First bad revision: bb6c41fbe8bc87bb14df5d56ac048cc540e853f9
14:19.44 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2a63a6c35033b5cbc6c98cabc7657c7290284691&tochange=bb6c41fbe8bc87bb14df5d56ac048cc540e853f9

So I ran again.  Turns out 55 is broken too, and so is 52, and so is 40... this is not some recent regression.

The puzzling thing is that sometimes the toolbar hiding works ok, but more often than not it will stick around until you create and then dismiss some transient popup, or toggle fullscreen off and then on again with no focus on the URL bar.

Right now I can't seem to reliably reproduce "good" behavior on any of the versions mentioned above.

I ran mozregression once again, starting with 33 as the good version:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e631971b841&tochange=0b81c10a9074

There's bug 515196 related to autohide.  Which leads us to bug 1195927, which this bug seems to be a duplicate of.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1195927
Marking fix-optional so that we will only track this issue in the duplicate.
You need to log in before you can comment on or make changes to this bug.