Closed Bug 1403971 Opened 2 years ago Closed 2 years ago

Update webrender to aa81aebba2c1b8ff8af5d40796154d66349fd131

Categories

(Core :: Graphics: WebRender, enhancement, P3)

58 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1402321 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ 39e6038ce209a63e4bbbd095e9739f97d92220ec

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e8f089706c77eccfb5187888270842488314b32a
https://treeherder.mozilla.org/#/jobs?repo=try&revision=acafe9058899942d3a1da35e734516dfb97298f7

There's some fail with this panic:

thread '<unnamed>' panicked at 'assertion failed: pass.max_used_color_target_size.width > 0', /builds/worker/workspace/build/src/gfx/webrender/src/renderer.rs:3043

Regression range:

* 39e6038c Auto merge of #1758 - glennw:small-target, r=kvark
* 3a5b7923 Initialize render targets to the required size, saving memory and clear time.
WR @ 30de644f426efd7c8c7aea59d4c4047d412fa598

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4485c663f69f08f9f8c0a0274fcaa1de4a1fe1e5
https://treeherder.mozilla.org/#/jobs?repo=try&revision=89fd9adc53f6d6ec58e8dd283e12c6b481da131c

WR @ ba51d8d5892d7ff8a69a9657c882b620595de4f7

https://treeherder.mozilla.org/#/jobs?repo=try&revision=da6d11c43fc9d13156e8f5c8f7eb4db775fdcb00
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2717de356f811883cf5dd5a3babd4b51c64a7c9c

More of the same. And there's an opt R4 failure that I thought was intermittent but seems to have persisted. So that would have the same regression range as noted in comment 1.

The reftest output was broken recently so that some of those try pushes don't show anything in the reftest analyzer, but it's fixed now so the most recent try push does show stuff. Here's a link for the R4 failure:

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/JqwZiFZMQayAE8Pj3ZLEVQ/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

This looks like it can just be fuzzed away, since visually the pages look the same. The test was already marked fuzzy-if(webrender,8-8,242-242) and we need to expand that to 8-8,255-255.
WR @ 66e02ff7986938a7aa25af13c474a1b1798b39b0

https://treeherder.mozilla.org/#/jobs?repo=try&author=kgupta@mozilla.com&fromchange=2e59f05920424bfa9994c5546e3bcec391646fcb&group_state=expanded&tochange=78f288c05dfe2e1c6aceb34733be05323cec2557

The upstream change in servo/webrender#1758 was reverted, so these are mostly green except for the unexpected-pass in R4 which is a result of the increase in fuzziness that I added to my patch queue. If I remove that it should be back to green.
Alias: wr-future-update
Assignee: nobody → bugmail
Blocks: 1404955
No longer blocks: 1405359
Summary: Future webrender update bug → Update webrender to aa81aebba2c1b8ff8af5d40796154d66349fd131
Version: unspecified → 58 Branch
Comment on attachment 8914834 [details]
Bug 1403971 - Update webrender to commit aa81aebba2c1b8ff8af5d40796154d66349fd131.

https://reviewboard.mozilla.org/r/186106/#review191120
Attachment #8914834 - Flags: review?(mstange) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01d20d2ebb57
Update webrender to commit aa81aebba2c1b8ff8af5d40796154d66349fd131. r=mstange
https://hg.mozilla.org/mozilla-central/rev/01d20d2ebb57
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.