Closed Bug 1404558 Opened 4 years ago Closed 4 years ago

regression: Crash in [@ mozalloc_abort | abort | core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ]

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: jan, Assigned: Gankra)

References

(Blocks 1 open bug, )

Details

(Keywords: crash, nightly-community, regression, Whiteboard: [wr-mvp])

Crash Data

Regression? Just updated to this build before the quoted crash happened.

(Jan Andre Ikenmeyer [:darkspirit] from bug 1374622 comment 19)
> Nightly 58 x64 20170929220356 de_DE @ Debian Testing (KDE/Radeon RX480)
> gpu process + layers force accel + webrender (layersfree) + webrendest +
> blob-images
> 
> https://techcrunch.com/2017/09/29/its-time-to-give-firefox-another-chance/
> 
> Crash just by scrolling down that page. (It doesn't scroll, flickers once
> and I see a new crash report.)
> 
> > MOZ_CRASH Reason: Should have been allocated by now!
> 
> Meldungs-ID 	Sendedatum
> bp-baa670e2-9476-46e6-9526-3341b0170930	30.09.17 03:47
> bp-ba22b174-be56-456d-b330-f6ada0170930	30.09.17 03:47
> bp-7604ccd3-606f-4507-934c-330200170930	30.09.17 03:45
> bp-844be0bb-0909-4362-90e1-a499a0170930	30.09.17 03:45
> bp-d27af249-3f0c-4cc5-b069-34a0e0170930	30.09.17 03:45
> bp-53e5f131-3d96-44df-b453-cecc60170930	30.09.17 03:44
> bp-06e9f98d-14d5-42af-b1e8-d7a710170930	30.09.17 03:44
> bp-81c10756-341c-43ab-a9fc-aac620170930	30.09.17 03:44
> bp-8ff68042-1ad7-4beb-8e1a-061cf0170930	30.09.17 03:44

Also seen on Youtube.

bp-2efef380-bb5d-4bbc-82f4-209990170930	30.09.17 04:09
bp-8fdcbdb4-a25c-4658-8c3d-16bdf0170930	30.09.17 04:09
bp-66dd8455-5eb9-4d14-b9f4-2016a0170930	30.09.17 04:09
bp-ce516f67-b4e5-41d9-8ab0-dc14b0170930	30.09.17 04:09
bp-61b44d31-65e2-4031-beeb-ceccc0170930	30.09.17 04:08
bp-7dce57ec-c0b7-4d6b-a366-785150170930	30.09.17 04:08
bp-1bbf652e-26dc-47c6-ba0b-8270b0170930	30.09.17 04:08
layers.acceleration.force-enabled;true
layers.gpu-process.enabled;true
layers.gpu-process.force-enabled;true
layers.gpu-process.max_restarts;1000
gfx.webrender.blob-images;true
gfx.webrender.enabled;true
gfx.webrendest.enabled;true

Visited https://techcrunch.com/2017/09/29/its-time-to-give-firefox-another-chance/
and scrolled down. If it flickerd white and didn't scroll, it was a bad build.

> mozregression --good 2017-09-28 --bad 2017-09-30 --profile-persistence clone-first
> [...]
> 10:32.75 INFO: Last good revision: e365cc4aa8f1d3d7bfc6ace91522896cbaf3741a
> 10:32.75 INFO: First bad revision: 754da8e698978a5d21542fd1f35ac250c2768077
> 10:32.75 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e365cc4aa8f1d3d7bfc6ace91522896cbaf3741a&tochange=754da8e698978a5d21542fd1f35ac250c2768077

May be this one:
>  Bug 1402321 - Update webrender to commit 9c5f8682e75839ad8c26480b89f87bbb37aa7894. r=jrmuizel


I had to manually "skip" some builds that wanted to start in "Safe Mode". If I do not skip and type "bad" I get
>  5:27.11 INFO: Last good revision: e365cc4aa8f1d3d7bfc6ace91522896cbaf3741a
>  5:27.11 INFO: First bad revision: 13e8329439654bbf9c888d37c6abb342d114a8cd
>  5:27.11 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e365cc4aa8f1d3d7bfc6ace91522896cbaf3741a&tochange=13e8329439654bbf9c888d37c6abb342d114a8cd
which doesn't make sense.
Has Regression Range: --- → yes
Has STR: --- → yes
Windows: [@ core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ]

Seen on Socorro:
20170919100405 bp-17bae8fe-5409-4422-8d88-b5ae50170919
> MOZ_CRASH Reason 	Each render task must allocate <= size of one target! (1258×24)
= old "see also" bug

Then no crash for about 10 days.

Spike since yesterday:
20170929220356 bp-337d5081-7f3d-4650-816a-222bb0170930
> MOZ_CRASH Reason 	Should have been allocated by now!
Crash Signature: [@ mozalloc_abort | abort | core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ] → [@ mozalloc_abort | abort | core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ] [@ core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ]
Summary: Crash in [@ mozalloc_abort | abort | core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ] → regression: Crash in [@ mozalloc_abort | abort | core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ]
Oh, there is a second new crash reason:
bp-d57f94a9-6b05-4724-b652-0bc390170930 (my Debian Testing)
> MOZ_CRASH Reason 	handle not requested or allocated!
Crash Signature: [@ mozalloc_abort | abort | core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ] [@ core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ] → [@ mozalloc_abort | abort | core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ] [@ core::option::expect_failed | webrender::frame_builder::FrameBuilder::build ] [@ mozalloc_abort | abort | core::option::expect_failed | webrende…
OS: Linux → All
Leaving 58 unaffected only because WebRender is off by default.
Priority: -- → P2
Whiteboard: [wr-mvp]
This is the #3 Windows topcrash in Nightly 20171002100134, with 81 occurrences.
Just landed a WR update that should fix at least some of these (the chosen signature is so generic that it covers almost every crash in processing the display list). Should show up in the next nightly.
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #0)
> > Nightly 58 x64 20170929220356 de_DE @ Debian Testing (KDE/Radeon RX480)
> > gpu process + layers force accel + webrender (layersfree) + webrendest + blob-images
> > 
> > https://techcrunch.com/2017/09/29/its-time-to-give-firefox-another-chance/
> > 
> > Crash just by scrolling down that page. (It doesn't scroll, flickers once  and I see a new crash report.)

Nightly 58 x64 20171003220138 (includes bug 1403971, Tue Oct 03 20:25:55 2017 +0000) de_DE @ Debian Testing.
At least this STR (+ gpu process crash on transaction overview in my online banking) do not work for me anymore.
Last crashes with 20171003100226. My 20171003220138 (12 hours later) was fine (comment 9).

Fixed by https://github.com/servo/webrender/issues/1779 / bug 1403971.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Version: Trunk → 58 Branch
Target Milestone: --- → mozilla58
Version: 58 Branch → Trunk
Priority: P2 → P1
Verified: Last crash with build: 20171003100226. Thank you.
The upstream fix was from Gankro, but this FIXED bug is (was) still unassigned.
Assignee: nobody → a.beingessner
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.