Closed Bug 1405569 Opened 2 years ago Closed 2 years ago

2.76 - 3.24% installer size (linux32, linux64, osx-cross, windows2012-32, windows2012-64) regression on push 6286471c1882a6602f916882d4bf5ae42f81f485 (Tue Oct 3 2017)

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 + fixed
firefox58 --- fixed

People

(Reporter: igoldan, Assigned: jaws)

References

Details

(Keywords: regression)

Attachments

(1 file)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=6286471c1882a6602f916882d4bf5ae42f81f485

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  installer size summary windows2012-32 pgo      55,332,803.08 -> 57,123,403.58
  3%  installer size summary windows2012-64 pgo      59,424,219.25 -> 61,222,582.67
  3%  installer size summary linux64 pgo             62,337,921.50 -> 64,144,118.67
  3%  installer size summary osx-cross opt           65,269,236.75 -> 67,085,038.50
  3%  installer size summary linux32 pgo             63,399,502.17 -> 65,151,288.08


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=9807

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Jared, is there something we can do to reduce the size of the builds? Or should we accept these regressions?
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Did you resize the asset yourself, or did we get a new asset from UX?
Flags: needinfo?(jaws)
I resized the asset myself and ran it through pngcrush to make sure that it was as optimized as we could get. I am not sure who on UX created this and bug 1405009 doesn't mention.
Flags: needinfo?(jaws)
The new patch I'm attaching switched to a JPG with better overall compression and a hard-coded background color to match the preferences background color.
Comment on attachment 8915167 [details]
Bug 1405569 - Reduce critters-postcard.png to 664x664 since that is the maximum size of the preferences container.

https://reviewboard.mozilla.org/r/186420/#review191582

Patch looks okay, but going to do a ui-r? for shorlander to see if he (or mart3ll?) is okay with this size reduction technique, or would prefer to try to re-render the image at a smaller size and with the hardcoded background using the software that generated the image.
Attachment #8915167 - Flags: review?(mconley) → review+
Comment on attachment 8915167 [details]
Bug 1405569 - Reduce critters-postcard.png to 664x664 since that is the maximum size of the preferences container.

Redirecting...
Attachment #8915167 - Flags: ui-review?(shorlander) → ui-review?(smartell)
mart3ll looked at it and said that it looks great to him. landing now...
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f9785f205814
Reduce critters-postcard.png to 664x664 since that is the maximum size of the preferences container. r=mconley
Comment on attachment 8915167 [details]
Bug 1405569 - Reduce critters-postcard.png to 664x664 since that is the maximum size of the preferences container.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1405009 which was uplifted to 57
[User impact if declined]: larger installer size
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]:  no
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple image swap
[String changes made/needed]: none
Attachment #8915167 - Flags: approval-mozilla-beta?
[Tracking Requested - why for this release]: installer size increase for 57 (regressing patch was uplifted to 57)
Comment on attachment 8915167 [details]
Bug 1405569 - Reduce critters-postcard.png to 664x664 since that is the maximum size of the preferences container.

Recent regression, Beta57+
Attachment #8915167 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This fixed the installer size regression.

== Change summary for alert #9848 (as of October 05 2017 14:56 UTC) ==

Improvements:

  3%  installer size summary windows2012-32 pgo      57,104,564.75 -> 55,420,893.25
  3%  installer size summary windows2012-64 pgo      61,160,003.58 -> 59,480,321.17
  3%  installer size summary linux64 pgo             64,187,809.75 -> 62,457,463.67
  3%  installer size summary linux32 pgo             65,189,352.42 -> 63,475,593.00
  3%  installer size summary osx-cross opt           67,061,890.58 -> 65,379,892.33

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=9848
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
You need to log in before you can comment on or make changes to this bug.