Failed search in prefs could do something different

RESOLVED FIXED in Firefox 57

Status

()

defect
P5
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: Dolske, Assigned: jaws)

Tracking

Trunk
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed, firefox58 fixed)

Details

Attachments

(2 attachments)

This grew out of a discussion of having a bit of an easter-egg for 57, subject to the constraints of doing something late. Something simple that involves a new feature that lets us highlight the new critters Martell did for 57 in-content pages. The request refined to this:

Currently, if you perform a search in preferences (new feature!) but there are no matching results, we show a little "Sorry!" message and the error bear illustration (browser/themes/shared/incontentprefs/no-search-results.svg).

We'd like to add a special case when searching for the fire-emoji + fox-emoji ("
Ha. Ha. *cries* Not only does Bugzilla still not accept emoji, it still just truncates the entire comment instead of stripping them out.

So, to try and remember the rest of what I typed...

We'd like to add a special case when searching for the fire-emoji + fox-emoji. Instead of showing the berror illustration as normal, it should show the new Martell illustration attached here. (Bonus points for a fun reveal transition/animation, we couldn't think of anything compelling.) This helps draw attention to a new feature, is simple to build, and avoids new strings.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
For the transition, perhaps we start with the berror, then the screen quickly flashes white, and fades out to reveal the postcard image, which slowly rotates to its final position?  Kinda like https://www.youtube.com/watch?v=QYnw9a9nCWQ but about 80% less cheesy? ;)
Posted patch Patch for bugSplinter Review
Attachment #8914474 - Flags: review?(dolske)
Priority: -- → P5
Comment on attachment 8914474 [details] [diff] [review]
Patch for bug

Review of attachment 8914474 [details] [diff] [review]:
-----------------------------------------------------------------

Yoink. This looks good to me - good idea to use the query as an attribute! That simplifies things nicely.
Attachment #8914474 - Flags: review?(dolske) → review+
(In reply to Mike Conley (:mconley) (:⚙️) - Backlogged on reviews from comment #4)
> Comment on attachment 8914474 [details] [diff] [review]
> Patch for bug
> 
> Review of attachment 8914474 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Yoink. This looks good to me - good idea to use the query as an attribute!
> That simplifies things nicely.

Thanks I thought it was a nice touch and a cool way for someone to stumble upon the Easter Egg :)
Comment on attachment 8914474 [details] [diff] [review]
Patch for bug

Approval Request Comment
[Feature/Bug causing the regression]: n/a
[User impact if declined]: cute Easter Egg related to Photon will be sorely missed
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: adds an image if the user searches for an emoji pair
[String changes made/needed]: none
Attachment #8914474 - Flags: approval-mozilla-beta?
(In reply to Justin Dolske [:Dolske] from comment #1)
> Ha. Ha. *cries* Not only does Bugzilla still not accept emoji, it still just
> truncates the entire comment instead of stripping them out.

Is there a bug for that? This is at least the third time I've seen it happen...

(Also, I'm here because this is the kind of commit message you can't not look at the bug for...)
https://hg.mozilla.org/mozilla-central/rev/6286471c1882
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
(In reply to Kris Maglione [:kmag] (long backlog; ping on IRC if you're blocked) from comment #8)
> 
> (Also, I'm here because this is the kind of commit message you can't not
> look at the bug for...)

Yeah, in retrospect, we probably could have been a bit more coy with the commit message. ¯\_(ツ)_/¯
Comment on attachment 8914474 [details] [diff] [review]
Patch for bug

New photon stuff, Beta57+
Attachment #8914474 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Maybe change the commit message for the uplift? ;)
Group: mozilla-employee-confidential
See Also: → 1455990
You need to log in before you can comment on or make changes to this bug.