Closed Bug 1405634 Opened 3 years ago Closed 1 year ago

Add-on popups close when focusing password input field

Categories

(Core :: Widget: Gtk, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1451466

People

(Reporter: ruben.grimm, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171004000618

Steps to reproduce:

Install an add-on that has a popup with a password field (in my case: pass-browser-firefox and passman).

Click on the add-on icon. (With pass-browser-firefox, the popup only opens for a short time, since the add-on instantly focuses the password field.)

Focus the password field (click into it).


Actual results:

The add-on popup closes.


Expected results:

The add-on popup stays open, focuses the password input, and I can input my password.
Work for me in Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0 ID:20171004220309 & Fx57.0b5, with Passman 2.0.3.
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
I'm on Fedora 26.

I tried to use a fresh Firefox profile -> Same problem.
I also tried current Firefox Nightly -> Same problem.
When switching to the Wayland Session in Fedora (I was using X11 previously) it works.
Component: WebExtensions: Untriaged → Widget: Gtk
Product: Toolkit → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Also seeing this behavior on Linux/X11 with Bitwarden and Lastpass
Just confirmed that switching to Wayland from default X11 seems to solve the issue.
See Also: → 1451418
Confirmed not working on Ubuntu 18.04 default. Tested with BitWarden.
This bug also affects me on a fresh installed Ubuntu 18.04 machine.
Can confirm. Fresh new install of Ubuntu 18.04 and experiencing this with bitwarden.
Anyone knows of a workaround for this problem? It made Firefox unusable for me.
@Diep Switching to Wayland solves this issue for me.
> Switching to Wayland solves this issue for me.

Unfortunately the Wayland session doens't work for me, I guess because incompatible with NVDIA video card.
If you open the Bookmarks sidebar, you can click on the header and select BitWarden and use it in sidebar mode, and it does not have issues.
(In reply to Diep Pham from comment #11)
> > Switching to Wayland solves this issue for me.
> 
> Unfortunately the Wayland session doens't work for me, I guess because
> incompatible with NVDIA video card.

check out https://bugzilla.mozilla.org/show_bug.cgi?id=1451418#c4 you can toggle it on/off until this gets fixed.
> If you open the Bookmarks sidebar, you can click on the header and select BitWarden and use it in sidebar mode, and it does not have issues.

Bitwarden is easy to workaround, I just stop using the extension altogether and rely on copy/paste from the desktop client. The real annoying one is the Metamask addon.

> check out https://bugzilla.mozilla.org/show_bug.cgi?id=1451418#c4 you can toggle it on/off until this gets fixed.

Thank for the tip, but after ui.popup.disable_autohide = true I couldn't figure out how to close those popups except going to about:config and toggle autohide again.
FYI, the bug might be in Ibus package, not firefox https://github.com/ibus/ibus/issues/2002#issuecomment-386537208.
I rebuild the ibus-gtk3 package myself with ibus-xx-f19-password patch included and it appear to fixed the problem! I attached the .deb here if anyone wants to try.
I installed this package and worked as expected.
Do I need to reboot the machine or restart firefox after installing this package?
I installed Diep Pham's modified version of the Ibus package, restarted Firefox, and Bitwarden popup worked perfectly.
Depends on: 1451466
(In reply to Diep Pham from comment #16)
> Created attachment 8974077 [details]
> ibus-gtk3_1.5.17-3ubuntu4_amd64.deb
> 
> I rebuild the ibus-gtk3 package myself with ibus-xx-f19-password patch
> included and it appear to fixed the problem! I attached the .deb here if
> anyone wants to try.

Yes!!! At last! Thank you so much... This bugs me from the beginning of Firefox Quantum, and first time I saw it using LastPass... Thinking it was their fault, I switched to BitWarden... Staying to BitWarden for now... Thank you so much for providing a patch!
(In reply to Diep Pham from comment #14)
> 
> Bitwarden is easy to workaround, I just stop using the extension altogether
> and rely on copy/paste from the desktop client.

I saw you already solved your issue with the deb package. Anyway, instead of using BitWarden Desktop client, you can just use it in sidebar (Shift+Alt+U)... After logged in, it works flawless again.
So as it is confirmed a bug in Gnome Shell: https://gitlab.gnome.org/GNOME/gnome-shell/issues/391, should we just close this issue?
I can confirm the bug

(In reply to Diep Pham from comment #22)

So as it is confirmed a bug in Gnome Shell:
https://gitlab.gnome.org/GNOME/gnome-shell/issues/391, should we just close
this issue?

Sure -- I'll close this as a duplicate of the main bug that was tracking this issue. (bug 1451466)

Also, good news: a fix has just been released in Ubuntu Bionic (18.04) - so if you install updates & and maybe reboot, this should be fixed for you.

See recent comments on https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1765304 for more (https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1765304/comments/64 in particular)

Status: NEW → RESOLVED
Closed: 1 year ago
No longer depends on: 1451466
Resolution: --- → DUPLICATE
See Also: 1451418
Duplicate of bug: 1451466
You need to log in before you can comment on or make changes to this bug.