Closed Bug 1406119 Opened 3 years ago Closed 3 years ago

Unable to scroll on about:preferences

Categories

(Core :: Graphics: WebRender, defect, P1)

Other Branch
defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: kats, Assigned: kats)

References

Details

(Keywords: nightly-community, Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(1 file)

Spinoff from https://bugzilla.mozilla.org/show_bug.cgi?id=1406008#c5:

Jan Andre Ikenmeyer [:darkspirit] from bug 1406008 comment 5:
> layers force accel + webrender
> 
> "bad" is when I am not able to scroll down on about:preferences when
> webrender is enabled.
> 
> > mozregression --good 2017-10-03 --bad 2017-10-05 --profile-persistence clone-first
> > [...]
> > 6:09.50 INFO: Last good revision: 29a20bc04c6f95f8014238511d2cce7f299fabf3about:preferences
> > 6:09.50 INFO: First bad revision: 6869bf44878df743ee848048954a959f77d5d9d7
> > 6:09.50 INFO: Pushlog:
> > https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=29a20bc04c6f95f8014238511d2cce7f299fabf3&tochange=6869bf44878df743ee848048954a959f77d5d9d7
> 
> Bug 1404782 - Do not mutate display list in layers-free mode. r=mattwoodrow

My investigation:

Kartikaya Gupta (email:kats@mozilla.com) from bug 1406008 comment 6:
> It looks like the patch adds a recursive call at [1] which is not handled
> properly. The code assumes that only recursion that can happen is at [2] and
> does a whole bunch of stuff beforehand (e.g. recording stuff like
> layerCountBeforeRecursing and all the things inside the apzEnabled block)
> and that's not happening around this new recursive call site. That's going
> to result in the event regions being all messed up which could very well
> explain the bad scrolling.
> 
> [1] https://hg.mozilla.org/integration/autoland/rev/db40593b664c#l1.58 
> [2]
> http://searchfox.org/mozilla-central/rev/
> 7ba03cebf1dcf3b4c40c85a4efad42a5022cf1ec/gfx/layers/wr/WebRenderLayerManager.
> cpp#333-335
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → All
Hardware: Unspecified → All
Comment on attachment 8915683 [details]
Bug 1406119 - Ensure that we do all the necessary APZ prep before recursing.

https://reviewboard.mozilla.org/r/186882/#review192070

Thanks. I followed the FLB's way to process the display list, but I didn't think of this.
Attachment #8915683 - Flags: review?(ethlin) → review+
No worries, the code is really convoluted and I hope to delete it soon ;)
hg error in cmd: hg pull upstream: pulling from https://hg.mozilla.org/integration/autoland
searching for changes
abort: HTTP Error 500: Internal Server Error
Priority: P3 → P2
Whiteboard: [gfx-noted][wr-mvp][triage] → [wr-mvp] [gfx-noted]
Status: NEW → ASSIGNED
Priority: P2 → P1
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eaaaba7a4a80
Ensure that we do all the necessary APZ prep before recursing. r=ethlin
https://hg.mozilla.org/mozilla-central/rev/eaaaba7a4a80
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Verified fixed in Nightly 58 x64 20171008131700 @ Debian Testing.
Thank you!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.