Closed Bug 1406245 Opened 2 years ago Closed 1 year ago

Crash in CoreVideo@0x2d6d on OS X 10.13

Categories

(Core :: Audio/Video: Playback, defect, P2, critical)

Unspecified
macOS
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mccr8, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [tbird crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-40320b6e-9064-43e0-b84f-073c60171005.
=============================================================

OSX 10.13 specific crash signature. I'm assuming that CoreVideo is video playback related. 101 crashes across all versions.

one comment: "I simply plugged in my external display using a DisplayPort cable."
Blocks: highsierra
Exclusively 10.13, and the crashing stack is entirely CoreVideo/libSystem. Makes me wonder if maybe this is really an Apple bug?
One of the comments says "I simply plugged in my external display using a DisplayPort cable" - I wonder if this is another manifestation of plugging/unplugging devices from the ports.
(In reply to Alex Gaynor [:Alex_Gaynor] from comment #1)
> Exclusively 10.13, and the crashing stack is entirely CoreVideo/libSystem.
> Makes me wonder if maybe this is really an Apple bug?

I'm wondering if it is a sandboxing issue, see bug 1403855.
See Also: → 1403855
Flags: needinfo?(jmathies)
Flags: needinfo?(jmathies)
I can't reproduce with an external monitor on Mac OS X 10.13. Seems to be happening across a wide range of GPUs.
Priority: -- → P2
Summary: Crash in CoreVideo@0x2d6d → Crash in CoreVideo@0x2d6d on OS X 10.13
Should I file an Apple bug on this one?
bp-02e42b96-1693-475d-8335-bc0f70171009 Thunderbird 52.3.0 Mac was sleeping and Thunderbird was crashed when I woke it up. 
bp-3c23537f-823d-4e62-b3f0-b151b0171023 Firefox 57.0b10 come out of sleep ... and wasn’t actively using Firefox.
Whiteboard: [tbird crash]
That said, miket had a few of these crashes, none in the last week but is now seeing a few CVCGDisplayLink::getDisplayTimes

Perhaps coincidence, but that signature has seen a noticeable increase in Firefox crash rate around Nov 1-2.  See the graph https://crash-stats.mozilla.com/signature/?signature=CVCGDisplayLink%3A%3AgetDisplayTimes&date=%3E%3D2017-10-10T13%3A52%3A03.000Z&date=%3C2017-11-10T11%3A52%3A03.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1#graphs
I got one just a few mins ago (after returning from heating up my lunch): https://crash-stats.mozilla.com/report/index/a7a1b9f3-be0a-41fb-9759-8d0b30171113
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
You need to log in before you can comment on or make changes to this bug.