Closed Bug 1406276 Opened 2 years ago Closed 2 years ago

Update Folder Icon

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: shorlander, Assigned: shorlander)

References

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(1 file)

Update the folder icon to fix some overlapping shapes.
Attachment #8915818 - Flags: review?(jhofmann)
\o/
Comment on attachment 8915818 [details] [diff] [review]
update-folder-icon.patch

Review of attachment 8915818 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great on my machine, thank you.
Attachment #8915818 - Flags: review?(jhofmann) → review+
Inbound is closed and I don't want to add noise, setting checkin-needed.
Flags: qe-verify-
Keywords: checkin-needed
Priority: -- → P1
Whiteboard: [photon-visual] → [reserve-photon-visual]
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/008faf413e3c
Update Folder Icon to fix some overlapping areas. r=jhofmann
Keywords: checkin-needed
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/008faf413e3c
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Verified in Nightly on Win10x64, much better!

Btw, not related to this bug, but looks like the fill-opacity is not correctly applied to the sidebar and the Library Window. It seems to only be applied to the main browser window.
I filed bug 1406620 for that separate issue.
Comment on attachment 8915818 [details] [diff] [review]
update-folder-icon.patch

Approval Request Comment
[Feature/Bug causing the regression]: new Photon design
[User impact if declined]: Bookmarks folders icons are bold and look particularly bad with Dark theme
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]:  no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: replacing an svg icon
[String changes made/needed]: none
Attachment #8915818 - Flags: approval-mozilla-beta?
Comment on attachment 8915818 [details] [diff] [review]
update-folder-icon.patch

Photon polish, Beta57+
Attachment #8915818 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.