Support styloVsGecko tests on Fennec/android

RESOLVED WONTFIX

Status

task
RESOLVED WONTFIX
2 years ago
Last year

People

(Reporter: m_kato, Unassigned)

Tracking

(Depends on 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
reftest-stylo doens't have android entry, so we should add it for styloVsGecko tests on Fennec/android.

WIP is https://treeherder.mozilla.org/#/jobs?repo=try&revision=67ac8d972c273a36665004ba68ee09199839c4f8
status-firefox57=wontfix unless someone thinks this bug should block 57
Makoto, do we still need to run the styloVsGecko reftests in automation on Android? I recall that you said the test failures were very fuzzy and not useful.
Flags: needinfo?(m_kato)
Reporter

Comment 3

2 years ago
(In reply to Chris Peterson [:cpeterson] from comment #2)
> Makoto, do we still need to run the styloVsGecko reftests in automation on
> Android? I recall that you said the test failures were very fuzzy and not
> useful.

All issues seems to be insignificant.  Also, android reftest has a bug such as bug 1413497 comment 6...  Most bugs might be same root cause.

I think that we don't need styloVsGecko for Android.  Because reftest is too slow on debug build (it requires 2hour x 48 servers) and most tests are covered by desktop test.
Flags: needinfo?(m_kato)
Reporter

Comment 4

2 years ago
(and we don't run web-platform-test on android ...)
(In reply to Makoto Kato [:m_kato] from comment #3)
> I think that we don't need styloVsGecko for Android.  Because reftest is too
> slow on debug build (it requires 2hour x 48 servers) and most tests are
> covered by desktop test.

In that case, I'll resolve this bug as WONTFIX. We're still running styloVsGecko on desktop and the regular reftests on Android, so our test coverage should be pretty good already.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Reporter

Updated

2 years ago
Depends on: 1413497
Reporter

Updated

2 years ago
Depends on: 1412774

Updated

Last year
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.