Closed Bug 1406291 Opened 3 years ago Closed 1 year ago

[Layout] floating table following quickly after page-break-after style is not printed

Categories

(Core :: Print Preview, defect, P3)

56 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox-esr68 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 + wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: yamamoto, Assigned: dbaron)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

931 bytes, text/html
Details
Attached file errFF56.html
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170926190823

Steps to reproduce:

W7 32bit, FF 56.0
Open example below and generatie print preview
This issue emerged in this version of FF.


Actual results:

Page two is not rebnered/printed correctly (Head 2 text is missing)


Expected results:

Obvious.
[Tracking Requested - why for this release]: Print broken, a line is missing.

I can reproduce the problem on Windows10 Nightly58.0a1.

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e6e712904806da25a9c8f48ea4533abe7c6ea8f4&tochange=d6bf703c5deaf1e328babd03d5e68ff2a4ffe10e

Regressed by: Bug 1308876

@:dbaron
Your bunch of patch seems to cause the problem. Can you look at this?
Blocks: 1308876
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dbaron)
Keywords: regression
Via local build,
Last good: 395b6c53e42b
First bad: 1e3130e96f03
[Tracking Requested - why for this release]:Bug 1308876 causes several print regression.
FYI -- I'm aware that a bunch of regressions from bug 1308876 turned up after it hit release (after none were reported while it was on nightly or beta).  See https://bugzilla.mozilla.org/show_bug.cgi?id=1308876#a30998038_3881 and below.  I'm going to try to look into them over the next week or two -- and hopefully there are fewer underlying problems than there are bug reports -- but these can be somewhat difficult bugs, so it might take a little time.
Makes sense to track this for 58, as we tracking some of the other issues noted in Comment 4.
Priority: -- → P3
I'd note that the align="left" is required, so this seems to be particular to the table floating.
Summary: First lines in table not printed after page break → floating table following quickly after page-break-after style is not printed
Summary: floating table following quickly after page-break-after style is not printed → [Layout] floating table following quickly after page-break-after style is not printed
Flags: needinfo?(dbaron)
Regressed by: 1308876
No longer regressed by: 1308876
No longer blocks: 1308876
Regressed by: 1308876

This is not fixed by bug 1474771, so it needs further investigation.

Will be fixed by bug 1420528.

Assignee: nobody → dbaron
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Flags: qe-verify+

Reproduced the issue on Firefox 69.0.1.
Verified fixed on Windows 7 x64, Windows 7 x86 and Windows 10 x64 using Firefox 70 Beta 9, buildID: 20190923154733 (using the example from Description).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.