Closed Bug 1406554 Opened 5 years ago Closed 5 years ago

Firefox nightly 58.0a1 (2017-10-06) (64-Bit) hlsa and rgba in userChrome.css

Categories

(Firefox :: Toolbars and Customization, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox56 --- unaffected
firefox57 --- wontfix
firefox58 --- wontfix

People

(Reporter: zitrobugs, Unassigned)

Details

Attachments

(4 files)

Attached video ff-beta-rgba.mp4
-I started Firefox nightly 58.0a1 (2017-10-06) or Firefox Beta 57.0b6 (64-bit)
-I opend Web-Developer--> Developer Toolbox-->Stylesheet Editor --> Create new Style
The Browser first is maximized!
I paste the following code in it:

[tabsintitlebar]:root:not(:-moz-lwtheme) {background-color: hsla(0, 0%, 0%, 0.8)!important}
or also the same effect with this red code:

[tabsintitlebar]:root:not(:-moz-lwtheme) {background-color: rgba(255, 0, 0, 0.5)!important}

wrong results:
- Color is black, the last value 0.8 or 0.5 is ignored if i open new Tab
- space over tabs
- My Windwos Taskbar get smaller and symbols in Windows Taskbar outstanding over the Taskbar

now i decrease Firefox and see new wrong results like:
- Space around Firefox (maybe relevant to Bug 1405593) 

now i maximize Firefox and see new wrong result:
- Firefox is over my Windows Taskbar

Code with #hex Code, has not such a wrong result, also normal Color like red, blue etc works fine.
Attached video ff-beta-rgba.mp4
Attached video ff-nightly-hsla.mp4
I forgot to write:
If i do for example the Code

[tabsintitlebar]:root:not(:-moz-lwtheme) {background-color: hsla(0, 0%, 0%, 0.8)!important}

in a userChrome.css
and start firefox, firefox start without surface, it is only visible a symbolicon in windows taskbar.
(Sorry, i uploaded ff-beta-rgba.mp4 attachment twice, and did not found where i could delete one)
On Firefox Beta 57.0b5 the problem is not reproducible
On Firefox Beta 57.0b6 the problem is reproducible
it seems a similarity with https://bugzilla.mozilla.org/show_bug.cgi?id=1405593#c15
This is happening because the colors specified have an alpha component (your #hex and named colors don't). I can reproduce this on Version	10.0.15063 Build 15063.

userChrome.css customizations are a land of their own and are generally not given a lot of support for weird corner cases like this. The rule you are attempting to set will create a translucent window which is not something that we would do often.

I'm going to mark this bug as a wontfix based on the previous paragraph.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.