Closed Bug 1405593 Opened 5 years ago Closed 5 years ago

Strange border of Firefox window with Windows 10 version 1511

Categories

(Core :: Widget: Win32, defect, P2)

57 Branch
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox56 --- unaffected
firefox57 - wontfix
firefox58 + wontfix

People

(Reporter: brindusat, Unassigned)

References

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

Attached image BugStrangeBORDER.jpg
[Affected versions]: 
Nightly 58.0a1, Build ID 20171003220138

[Affected platforms]:
Platforms: Windows 10

[Steps to reproduce]:
1. Launch Nightly with Default Theme.(with clean or old profile)
2. Make sure title bar is not enabled.
3. Observe Firefox window.

[Expected result]:
Firefox window should be displayed correctly

[Actual result]:
Firefox window has a strange border in the left, right and bottom of the window. 

Notes:
The tabs bar does not get the Windows accent color - it is black no matter what color I chose for Accent color. - should I log a separate bug for this?
Whiteboard: [photon-visual][triage]
I'm unable to reproduce this with the latest nightly on Windows 10.
Blocks: 1366405
No longer blocks: photon-visual
Tested it as well with a fresh install of 58, following the steps above I wasn't able to reproduce the border reported.
See Also: → 1403153
The rendering artifacts here look similar-ish to the ones in bug 1396840.

Brindusa, can you repro this on all win10 machines/resolutions? I assume not, in which case, can you narrow down where/when this happens?
Flags: needinfo?(brindusa.tot)
See Also: → 1396840
Attached video 2017-10-04_12h13_43.mp4
From my point of view, it seems to be a different issue than the one reported in bug 1396840.

I tried with different resolutions: 1920 x 1080, 1680 x 1050, 1600 x 1024 and it is reproducible on all of them. 

See the attached screencast with the browser behavior when focusing/unfocusing/hover tabs.
Flags: needinfo?(brindusa.tot)
Funky video. Does it reproduce on any other machine?

(working here on win10)
Flags: needinfo?(brindusa.tot)
Can you also please attach your about:support info?
A regression range would be nice too. I expect this is fallout from bug 1366405, but we need to get that confirmed. Also please check 56 and 57 beta.
Here is the regression window:

Last good revision: 82c2eecf82ba820c4593aa4a9749662f7d54d9a7
First bad revision: c4db9dfba44dc89ac669b314204fc1139dc75543

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=82c2eecf82ba820c4593aa4a9749662f7d54d9a7&tochange=c4db9dfba44dc89ac669b314204fc1139dc75543

From the pushlog, it seems that the bug 1403824 has caused this.
Flags: needinfo?(brindusa.tot)
Attached is the about:support.
(In reply to Brindusa Tot[:brindusat] from comment #8)
> Here is the regression window:
> 
> Last good revision: 82c2eecf82ba820c4593aa4a9749662f7d54d9a7
> First bad revision: c4db9dfba44dc89ac669b314204fc1139dc75543
> 
> Pushlog:
> https://hg.mozilla.org/integration/autoland/
> pushloghtml?fromchange=82c2eecf82ba820c4593aa4a9749662f7d54d9a7&tochange=c4db
> 9dfba44dc89ac669b314204fc1139dc75543
> 
> From the pushlog, it seems that the bug 1403824 has caused this.

Mike, could bug 1403824 have caused this e.g. by confusing win32 widget code in some way?
Blocks: 1403824
No longer blocks: 1366405
Flags: needinfo?(mh+mozilla)
I don't see how this could be related. Bug 1403824 barely did any practical change, and only a very specific kind of allocator metadata that is far from anything allocated.
Flags: needinfo?(mh+mozilla)
(In reply to Mike Hommey [:glandium] from comment #11)
> I don't see how this could be related. Bug 1403824 barely did any practical
> change, and only a very specific kind of allocator metadata that is far from
> anything allocated.

Brindusa, can you please double-check the regression range?
No longer blocks: 1403824
Flags: needinfo?(brindusa.tot)
(In reply to Dão Gottwald [::dao] from comment #12)
> 
> Brindusa, can you please double-check the regression range?

Dao, did it again this morning because it also seemed strange to me that these two bugs can be related. But I got the same result. I don't know if this help, but here is the first pushlog from autoland, the mozregression provides(there are a lot of bugs here):

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=82c2eecf82ba820c4593aa4a9749662f7d54d9a7&tochange=e365cc4aa8f1d3d7bfc6ace91522896cbaf3741a
Flags: needinfo?(brindusa.tot)
(In reply to Brindusa Tot[:brindusat] from comment #13)
> (In reply to Dão Gottwald [::dao] from comment #12)
> > 
> > Brindusa, can you please double-check the regression range?
> 
> Dao, did it again this morning because it also seemed strange to me that
> these two bugs can be related. But I got the same result. I don't know if
> this help, but here is the first pushlog from autoland, the mozregression
> provides(there are a lot of bugs here):
> 
> https://hg.mozilla.org/integration/autoland/
> pushloghtml?fromchange=82c2eecf82ba820c4593aa4a9749662f7d54d9a7&tochange=e365
> cc4aa8f1d3d7bfc6ace91522896cbaf3741a

bug 1366405 is in that range, but this means that beta should be affected too.
Blocks: 1366405
Flags: needinfo?(brindusa.tot)
Yes, it is reproducible on latest beta 57.0b6, build ID 20171005195903. 

Please note that on beta5 -  57.0b5, Build ID 20171002181526 this bug is not reproducible.
Flags: needinfo?(brindusa.tot)
[Tracking Requested - why for this release]:
Artifacts in rendering the main Firefox window on tier-1 OSes.
Priority: -- → P2
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
tracking as new visual regression in beta
I can also reproduce this issue using Fx 57.0b6(build ID: 20171005195903) and Fx 57.0b7(build ID:20171009192146), on Windows 10 x65(GPU: Intel HD 530).
I can also confirm that this issue is not reproducible using Fx 57.0b5(build ID: 20171002181526).
(In reply to Cristian Comorasu [:CristiComo] from comment #19)
> I can also reproduce this issue using Fx 57.0b6(build ID: 20171005195903)
> and Fx 57.0b7(build ID:20171009192146), on Windows 10 x65(GPU: Intel HD 530).
> I can also confirm that this issue is not reproducible using Fx 57.0b5(build
> ID: 20171002181526).

Could you please attach your about:support info like Brindusa did?
Flags: needinfo?(cristian.comorasu)
Also, what exact version of Windows 10 are you running?
Flags: needinfo?(brindusa.tot)
Sorry, forgot about it. Windows 10 Pro x64 (last comment was a typo, sorry)
Flags: needinfo?(cristian.comorasu)
(In reply to Cristian Comorasu [:CristiComo] from comment #22)
> Created attachment 8917295 [details]
> about_support_Fx57.0b7.txt
> 
> Sorry, forgot about it. Windows 10 Pro x64 (last comment was a typo, sorry)

Please run winver and let me know the exact version and build ID.
Flags: needinfo?(cristian.comorasu)
Attachment #8917296 - Attachment is obsolete: true
(In reply to Dão Gottwald [::dao] from comment #21)
> Also, what exact version of Windows 10 are you running?

With winver I get:
Microsoft Windows - Version 1511 (OS Build 10586.1106)
Flags: needinfo?(brindusa.tot)
Windows 10 x64, Version 1511 (OS Build 10586.1106) on Fx 57.0b6(build ID: 20171005195903) and Fx 57.0b7(build ID:20171009192146).
Flags: needinfo?(cristian.comorasu)
Attachment #8915611 - Attachment description: about_suport.txt → about_suport.txt (Win10 v. 1511 Build 10586.1106)
Attachment #8917295 - Attachment description: about_support_Fx57.0b7.txt → about_support_Fx57.0b7.txt (Win10 v. 1511 Build 10586.1106)
(In reply to Brindusa Tot[:brindusat] from comment #25)
> Microsoft Windows - Version 1511 (OS Build 10586.1106)

Are the machines where you cannot reproduce this bug running the same version of Windows 10?
Flags: needinfo?(cristian.comorasu)
Flags: needinfo?(brindusa.tot)
I tried on other 3 windows 10 machines and the bug is not reproducible on any of them with latest Nightly, and none of them has the same Windows Version as ours. Here are Windows 10 versions on the other test machines:
 - Windows 10 Version 1607 (OS Build 14393.1715)
 - Windows 10 Version 1703 (OS Build 15063.608)
 - Windows 10 Version 1703 (OS Build 15063.632)
Flags: needinfo?(brindusa.tot)
Okay, I guess only that outdated Windows 10 version from November 2015 is affected...
Component: Theme → Widget: Win32
Keywords: steps-wanted
Product: Firefox → Core
Summary: Strange border of firefox window → Strange border of Firefox window with Windows 10 version 1511
Version: 58 Branch → 57 Branch
(In reply to Dão Gottwald [::dao] from comment #29)
> Okay, I guess only that outdated Windows 10 version from November 2015 is
> affected...

Do we have telemetry on how many people are on the outdated version?
Flags: needinfo?(chutten)
(In reply to :Gijs (no reviews, PTO end of today - Nov) from comment #30)
> (In reply to Dão Gottwald [::dao] from comment #29)
> > Okay, I guess only that outdated Windows 10 version from November 2015 is
> > affected...
> 
> Do we have telemetry on how many people are on the outdated version?

We do. In the first week of October (Oct 1 - 7) we saw over one million users with os='Windows_NT' os_version='10.0' windows_build_number = 10586 and windows_ubr = 1106. That's a lot higher than I expected. Apparently it's the 6th-most-popular Windows 10 build amongst Firefox clients[1], at over 2% of the Windows 10 population.

[1]: https://sql.telemetry.mozilla.org/queries/775/source#table
Flags: needinfo?(chutten)
(In reply to Chris H-C :chutten from comment #32)
> (In reply to :Gijs (no reviews, PTO end of today - Nov) from comment #30)
> > (In reply to Dão Gottwald [::dao] from comment #29)
> > > Okay, I guess only that outdated Windows 10 version from November 2015 is
> > > affected...
> > 
> > Do we have telemetry on how many people are on the outdated version?
> 
> We do. In the first week of October (Oct 1 - 7) we saw over one million
> users with os='Windows_NT' os_version='10.0' windows_build_number = 10586
> and windows_ubr = 1106. That's a lot higher than I expected. Apparently it's
> the 6th-most-popular Windows 10 build amongst Firefox clients[1], at over 2%
> of the Windows 10 population.
> 
> [1]: https://sql.telemetry.mozilla.org/queries/775/source#table

Hm. Do we have a sense of how quickly that's declining? I looked at the sql query but it doesn't seem like there's any date selection in there, and it gets recreated every day, so not sure how to compare to previous sets. If this is going to be down further by the time we launch 57, maybe we don't care (also given comment #31).
Flags: needinfo?(chutten)
A quick scratch query shows that 10586.1106 isn't declining at all yet. At best it's holding steady. I don't know how quickly windows versions pass through the update population, so I don't know how quickly it might be able to decline when it starts.
Flags: needinfo?(chutten)
(In reply to Chris H-C :chutten from comment #34)
> A quick scratch query shows that 10586.1106 isn't declining at all yet. At
> best it's holding steady. I don't know how quickly windows versions pass
> through the update population, so I don't know how quickly it might be able
> to decline when it starts.

As noted in comment #29, this version is nearly 2 years old. Maybe the people on this old version are stuck for whatever reason (slow enterprise updates, or something) ? :-(
See Bug https://bugzilla.mozilla.org/show_bug.cgi?id=1406554 and this attachment https://bugzilla.mozilla.org/attachment.cgi?id=8917457 Windows 10 Version 1703 (OS Build 15063.674) and nightly 2017-10-11
This doesn't seem like a must fix in 57, specially given the win10 build it's reproducible is an unsupported version of win10 (comment 29). Untracked and wontfix for 57
Whiteboard: [reserve-photon-visual]
Duplicate of this bug: 1417845
Duplicate of this bug: 1417963
Duplicate of this bug: 1419319
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Note, we are tracking a similar issue with WebExtensions in https://bugzilla.mozilla.org/show_bug.cgi?id=1423626.
See Also: → 1423626
See Also: → 1431555
You need to log in before you can comment on or make changes to this bug.