Closed Bug 1406715 Opened 4 years ago Closed 4 years ago

In HTML5 fullscreen mode, the message box with the text "[...] is now full screen" moves the whole screen with it when it animates away

Categories

(Core :: Graphics: WebRender, defect, P1)

All
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: mstange, Assigned: mstange)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wr-reserve])

Attachments

(1 file)

Steps to reproduce:
 1. Enable webrender.
 2. Go to http://blogs.sitepointstatic.com/examples/tech/full-screen/index2.html
 3. Click the picture.
 4. Wait for the overlay "sitepointstatic.com is now full screen" to go away.

When it goes away, the whole screen briefly moves upwards and then snaps back down.

This can be retriggered by moving the mouse to the top edge of the screen, which will make the message appear again.

The same happens with fullscreen video on YouTube, for example.
Whiteboard: [wr-mvp] [triage]
Whiteboard: [wr-mvp] [triage]
I've reproduced this on both Mac and Windows.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment on attachment 8922206 [details]
Bug 1406715 - Use the RenderFrameParent's content rect as the bounds of the webrender iframe display item.

https://reviewboard.mozilla.org/r/193222/#review198556

Nice catch! Do you know if this also fixes the various bugs where web content ends up drawing over the toolbars and other UI? e.g. bug 1396298, bug 1403750
Attachment #8922206 - Flags: review?(bugmail) → review+
Whiteboard: [wr-reserve]
It fixes bug 1411959. The bugs that you mentioned seem to have been fixed already.
Blocks: 1411959
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/d9613617f268
Use the RenderFrameParent's content rect as the bounds of the webrender iframe display item. r=kats
https://hg.mozilla.org/mozilla-central/rev/d9613617f268
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Duplicate of this bug: 1404848
Regressions: 1609837
You need to log in before you can comment on or make changes to this bug.