Closed Bug 1609837 Opened 3 years ago Closed 3 years ago

nsDisplayRemote mixes up content rect offsets

Categories

(Core :: Web Painting, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

No description provided.
Blocks: R-fis
Regressed by: 1406715
Has Regression Range: --- → yes
Keywords: regression

There are two distinct fixes in this patch.

  1. Fix the rect we pass to EffectsInfo for both webrender and non-webrender case. The rect needs to be in coordinates of the subdocument but it was including the border/padding of the containing iframe. I also intersected it with the content rect so it doesn't extend outside of the subdocument, this doesn't fix anything AFAIK. I didn't track what caused this, it was likely in the first iteration of this code.

  2. For webrender we double included the content rect offset in the rect we passed to PushIFrame because GetContentRectLayerOffset already includes that offset. This part is a regression from bug 1406715.

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6d283db170d7
Fix content rect offsets in nsDisplayRemote. r=mattwoodrow
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74debaf6f6ae
Update expectations for fission reftest. CLOSED TREE
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Duplicate of this bug: 1604891
Duplicate of this bug: 1604892
Duplicate of this bug: 1604902
Duplicate of this bug: 1604904
Blocks: 1604896
Blocks: 1604900
You need to log in before you can comment on or make changes to this bug.