Closed Bug 1407719 Opened 3 years ago Closed 3 years ago

Fix failing xpcshell-test when building IB

Categories

(Instantbird :: Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1401528
Instantbird 58

People

(Reporter: arlolra, Unassigned)

References

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

Steps to reproduce:

./mozilla/mach xpcshell-test
Attachment #8917475 - Attachment is patch: true
Attachment #8917475 - Attachment mime type: text/x-patch → text/plain
Attachment #8917475 - Flags: review?(clokep)
Takes https://bugzilla.mozilla.org/show_bug.cgi?id=1407076 to run them.
I'm assuming this is necessary because the global `this` is now constructed without Object in its prototype chain, so `____defineGetter__` is undefined.

Also, the choice of which places to change was made by doing `git grep "^this.__defineGetter__"`.
(In reply to arlolra from comment #2)
> I'm assuming this is necessary because the global `this` is now constructed
> without Object in its prototype chain, so `____defineGetter__` is undefined.

The same change in m-c was done in bug 1363215.

> Also, the choice of which places to change was made by doing `git grep
> "^this.__defineGetter__"`.

The suite/ folder is SeaMonkey code, not Instantbird.
> The suite/ folder is SeaMonkey code, not Instantbird.

Should I remove that then?  I didn't think it would hurt.
(In reply to arlolra from comment #4)
> > The suite/ folder is SeaMonkey code, not Instantbird.
> 
> Should I remove that then?  I didn't think it would hurt.

Yes, either remove it or you need to get a separate review from one of the SeaMonkey people.
Attachment #8917475 - Attachment is obsolete: true
Attachment #8917475 - Flags: review?(clokep)
Attachment #8919485 - Flags: review?(clokep)
Attachment #8919485 - Flags: review?(clokep) → review+
Pushed by clokep@gmail.com:
https://hg.mozilla.org/comm-central/rev/7db605793963
Fix failing xpcshell-test when building IB
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 58
I had to back that out since it caused test failures:
https://hg.mozilla.org/comm-central/rev/ef6dca7cc6cd3ee6c718489be624c606597b34df

TEST-UNEXPECTED-FAIL | chat/modules/test/test_filtering.js | test_permissiveMode - [test_permissiveMode : 222] "<span style=\\"font-style: normal; font-weight: normal; font-size: 15px; font-family: normal;\\">foo</span>" == "<span style=\\"font-family: normal; font-style: normal; font-weight: normal; font-size: 15px;\\">foo</span>"
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
That's odd because it was necessary for the tests to pass locally for me.  Maybe the difference is because I'm building with `ac_add_options --enable-application=im`?
Updated the patch to remove the change to `chat/modules/test/test_filtering.js`

Note that this still results in a local failure for me but is safe to checkin.  Figuring out why the build target changes the result of that test can be a follow up.
mozilla/mach xpcshell-test chat/modules/test/test_filtering.js
passes locally with the latest version so I'll get his landed RSN(TM).
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4f4b4c62ffd1
Fix failing xpcshell-test when building IB. r=clokep
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
This breaks the display of the chat messages (nothing shown).
Error in the console: TypeError: property "gTheme" is non-configurable and can't be deleted[Learn More]  imSmileys.jsm:20:5

Back-out of this patch fixes it for me.

Jörg, please can you back-out this patch?
Flags: needinfo?(jorgk)
Backout as per comment #13 (I confirmed the malfunction and the "fix"):
https://hg.mozilla.org/comm-central/rev/85fa84e4ffdc2222075f8f69df5d81a90f798e49

I'll make sure we trigger a build so that's removed from the next Daily.
No longer blocks: 1410636
Status: RESOLVED → REOPENED
Flags: needinfo?(jorgk)
Resolution: FIXED → ---
The test failure from comment #8 will be fixed in bug 1420683.
Depends on: 1420683
We'll fix the remaining test failure in bug 1401528, see bug 1401528 comment #95.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1401528
You need to log in before you can comment on or make changes to this bug.