[DOGFOOD] Return doesn't close login/password dialog

VERIFIED DUPLICATE of bug 21868

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 21868
20 years ago
15 years ago

People

(Reporter: Bienvenu, Assigned: hangas)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

Mail/news is using the password prompt dialog, and it works well, except that
<RET> doesn't close the dialog. This is one of those really annoying useability
things - I hope it's not hard to fix...
Assignee: trudelle → sdagley
Target Milestone: M12
reassigning to sdagley as p2 for m12
Status: NEW → ASSIGNED
Summary: Return doesn't close login/password dialog → [DOGFOOD] Return doesn't close login/password dialog
I'd like this considered for dogfood.

davidm says the problem is with Ender not propogating the key event, so cc'ing
buster.
the ender-based gfx text controls do propogate key events.  An example of this
working is in the browser, where hitting Enter in the URL bar causes the URL to
load.
Could somebody try to build a reduced test case that illustrates the problem?
I'd be happy to look at it for dogfood if I could get a simple test case.
Whiteboard: [PDT-]
Not for dogfood...putting on PDT-
QA Contact: beppe → cpratt
mass-moving all m12 bugs to m13
adding myself to cc: list.
Assignee: sdagley → hangas
Status: ASSIGNED → NEW
Hangas asked for key behavior in dialog bugs to be sent his way...
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This is a dup of 21868, the fix for which I have in my local tree.


*** This bug has been marked as a duplicate of 21868 ***
Status: RESOLVED → VERIFIED
verified dup
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.