Press Enter should close the Password dialog

VERIFIED FIXED in M13

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: fenella, Assigned: hangas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in my local tree)

(Reporter)

Description

18 years ago
Linux Redhat 6.0 (1999-12-15-08 M12)
Wint_nt 4.0 (1999-12-15-09 M12)
Mac (1999-12-15-08 M12)
Steps:
1. Launch Messenger, select Edit|Account Setting
2. Click on Server from my account, uncheck the Save password checkbox,
Click OK.
3. In the folder pane, click on my account
4. Password dialog comes up
5. Enter your password and press Enter

Actual result: The password dialog has no response.

Expected result: Dialog should close

Paul said this will eventually works. Enter this bug to track.

This problem occurs on all three platforms.

Comment 1

18 years ago
I think we have a general bug on this somewhere on dialogs.  Maybe assigned to
davidm?
(Reporter)

Comment 2

18 years ago
On Linux (1999-12-15-08 M12)
Also, when pressing Enter in the New Card dialog on Linux, it does not close.
Comment it here to do the tracking.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Depends on: 9635
Target Milestone: M13

Comment 3

18 years ago
This is a duplicate of http://bugzilla.mozilla.org/show_bug.cgi?id=14078.

The address book part is probably a separate bug.  Do all the Linux dlgs not
close upon enter?
(Reporter)

Comment 4

18 years ago
All Unix dialogs do not close upon Enter. Please see bug 21963 to track this
problem.
(Assignee)

Updated

18 years ago
Whiteboard: fix in my local tree
(Assignee)

Comment 5

18 years ago
I have the fix for this in my local tree.  This fixes both the Enter/Return keys
and the Esc key for the password dialog.
(Assignee)

Comment 6

18 years ago
*** Bug 14078 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
I've been running with hangas' fix in my tree for a few days now.  It does fix
the problem (it's wonderful to have return work!) and I haven't seen any
problems with it.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

18 years ago
Fix checked in.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Verified as fixed on win32, macos, and linux using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-01-05-16-M13/sea
monkey32e.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/2000-01-05-15-
M13/netscape-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-01-05-15-M13/NSMacIn
staller-M13.sea.bin

I verified that the password dialog is closed after entering password and
pressing enter.  I checked it on IMAP and POP mail accounts.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.