Closed Bug 1407863 Opened 2 years ago Closed 2 years ago

stylo: layout/xul/test/test_splitter.xul fails

Categories

(Core :: CSS Parsing and Computation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1408235
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- affected

People

(Reporter: xidorn, Unassigned)

References

Details

Looking at the test, it seems that the <vbox>s around <splitter> are not expanded correctly. I suspect this may be related to the comment emilio left in nsSplitterFrame::Init somehow.

[1] https://searchfox.org/mozilla-central/rev/31606bbabc50b08895d843b9f5f3da938ccdfbbf/layout/xul/nsSplitterFrame.cpp#289-290
(Note that this is filed for annotating tests in the progress of bug 1407847. The test is not going to fail without patch there, because XUL is still using Gecko backend at the moment.)
Priority: -- → P3
Hmmm, now I strongly suspect this is actually from bug 1408235. Let's see if this disappears after we fix that bug.
Depends on: 1408235
(In reply to Xidorn Quan [:xidorn] UTC+10 (less responsive Nov 5 ~ Dec 16) from comment #2)
> Hmmm, now I strongly suspect this is actually from bug 1408235. Let's see if
> this disappears after we fix that bug.

Indeed. With my patch for bug 1408235, this test passes.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408235
You need to log in before you can comment on or make changes to this bug.