Closed Bug 1408261 Opened 4 years ago Closed 4 years ago

gfx/layers/wr/WebRenderBridgeParent.cpp:634:3: error: 'AutoProfilerTracing' was not declared in this scope

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: jbeich, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [wr-mvp])

Attachments

(1 file)

On Tier3 platforms without GeckoProfiler (iOS, Linux non-x86, BSDs, Solaris) the build is broken because "GeckoProfiler.h" doesn't define AutoProfilerTracing[1]. To reproduce on Tier1 platforms before bug 1371159 is fixed one has to force `return None` in gecko_profiler()[2].

In file included from objdir/gfx/layers/Unified_cpp_gfx_layers10.cpp:137:
gfx/layers/wr/WebRenderBridgeParent.cpp:634:3: error: unknown type name 'AutoProfilerTracing'
  AutoProfilerTracing tracing("Paint", "EmptyTransaction");
  ^
1 error generated.

http://buildbot.rhaalovely.net/builders/mozilla-central-amd64/builds/2235/steps/build/logs/stdio

[1] http://searchfox.org/mozilla-central/rev/ed1d5223adcd/tools/profiler/public/GeckoProfiler.h#613
[2] http://searchfox.org/mozilla-central/rev/ed1d5223adcd/toolkit/moz.configure#26
Whiteboard: [wr-mvp] [triage]
Whiteboard: [wr-mvp] [triage]
> status-firefox58: affected → unaffected

Is bug 1405481 going to be backed out? Otherwise, the error is impossible to work around on the affected platforms. --disable-webrender doesn't help.
Flags: needinfo?(milan)
(In reply to Jan Beich from comment #1)
> > status-firefox58: affected → unaffected
> 
> Is bug 1405481 going to be backed out?

No, but I can land a fix for this.
Assignee: nobody → bugmail
Flags: needinfo?(milan)
Status: NEW → ASSIGNED
Priority: P5 → P1
Whiteboard: [wr-mvp]
Comment on attachment 8918352 [details]
Bug 1408261 - Update profiler tracing stuff to use the new macro.

Thanks. This fixed build on FreeBSD. #ifdef MOZ_GECKO_PROFILER would have worked as well.

I wonder whether "required usage pattern" refers to bug 1403868.
Attachment #8918352 - Flags: feedback+
Yeah, that's the one. I didn't realize it landed so recently, nor the scope of the changes. It looks like I can also fix this by converting it to use the AUTO_PROFILER_TRACING macro instead, which is simpler than I thought.
Yes, that's the better fix. I think this patch just lost the race with bug 1403868.
Comment on attachment 8918352 [details]
Bug 1408261 - Update profiler tracing stuff to use the new macro.

https://reviewboard.mozilla.org/r/189150/#review194546
Attachment #8918352 - Flags: review?(mstange) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe87c31e80c4
Update profiler tracing stuff to use the new macro. r=mstange
Comment on attachment 8918352 [details]
Bug 1408261 - Update profiler tracing stuff to use the new macro.

This version also fixes FreeBSD build.
Attachment #8918352 - Flags: feedback+
(In reply to Jan Beich from comment #10)
> Comment on attachment 8918352 [details]
> Bug 1408261 - Update profiler tracing stuff to use the new macro.
> 
> This version also fixes FreeBSD build.

Thanks for verifying!
https://hg.mozilla.org/mozilla-central/rev/fe87c31e80c4
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
See Also: → 1410876
You need to log in before you can comment on or make changes to this bug.