Closed Bug 1408490 Opened 2 years ago Closed 2 years ago

Intermittent dom/plugins/test/mochitest/test_bug1092842.html | Test timed out.

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: intermittent-bug-filer, Assigned: sotaro)

References

Details

(Keywords: intermittent-failure, Whiteboard: [wr-mvp] [stockwell fixed:product])

Attachments

(2 files, 2 obsolete files)

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=136843562&repo=mozilla-inbound

https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-inbound-win64-stylo-disabled-debug/mozilla-inbound_win10_64_stylo_disabled-debug_test-mochitest-clipboard-e10s-bm109-tests1-windows-build112.txt.gz

09:51:00     INFO - TEST-START | dom/plugins/test/mochitest/test_bug1092842.html
09:51:00     INFO - GECKO(6612) | --DOCSHELL 000001A6614E2800 == 5 [pid = 4544] [id = {ac38e836-05da-4fff-a4bf-c184812e8ae5}]
09:51:00     INFO - GECKO(6612) | --DOCSHELL 000001A667B97000 == 4 [pid = 4544] [id = {00cc8591-367d-4b87-8428-ea54f18e9434}]
09:51:00     INFO - GECKO(6612) | --DOCSHELL 000001A6614FB800 == 3 [pid = 4544] [id = {0a4f2f21-902c-4976-91ef-c0fe4d5b188b}]
09:51:00     INFO - GECKO(6612) | ++DOMWINDOW == 18 (000001A667B97000) [pid = 4544] [serial = 53] [outer = 000001A668ADA000]
09:51:00     INFO - GECKO(6612) | [Child 4544, Main Thread] WARNING: stylo: Web Components not supported yet: file z:/build/build/src/dom/base/nsDocument.cpp, line 6457
09:51:00     INFO - GECKO(6612) | [Child 4544, Main Thread] WARNING: stylo: Web Components not supported yet: file z:/build/build/src/dom/base/nsDocument.cpp, line 6457
09:51:00     INFO - GECKO(6612) | For application/x-test found plugin nptest.dll
09:51:00     INFO - GECKO(6612) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\users\cltbld\appdata\local\temp\tmp74mxhz.mozrunner\runtests_leaks_plugin_pid3688.log
09:51:00     INFO - GECKO(6612) | [NPAPI 3688, Main Thread] WARNING: NS_ENSURE_TRUE(InitStaticMembers()) failed: file z:/build/build/src/modules/libpref/Preferences.cpp, line 5220
09:51:00     INFO - GECKO(6612) | [NPAPI 3688, Main Thread] WARNING: '!mInitialized', file z:/build/build/src/xpcom/threads/nsThreadManager.cpp, line 350
09:51:00     INFO - GECKO(6612) | [NPAPI 3688, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/xpcom/threads/nsThreadUtils.cpp, line 160
09:51:02     INFO - GECKO(6612) | --DOMWINDOW == 17 (000001A6614EE800) [pid = 4544] [serial = 42] [outer = 0000000000000000] [url = about:blank]
09:51:04     INFO - GECKO(6612) | --DOMWINDOW == 16 (000001A6614E1800) [pid = 4544] [serial = 44] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
09:51:04     INFO - GECKO(6612) | --DOMWINDOW == 15 (000001A6614E0800) [pid = 4544] [serial = 41] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/test_bug1028200-6.html]
09:51:04     INFO - GECKO(6612) | --DOMWINDOW == 14 (000001A6614F0000) [pid = 4544] [serial = 43] [outer = 0000000000000000] [url = about:blank]
09:51:08     INFO - GECKO(6612) | --DOMWINDOW == 13 (000001A6614FB000) [pid = 4544] [serial = 46] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageC.html]
09:51:08     INFO - GECKO(6612) | --DOMWINDOW == 12 (000001A6614FC000) [pid = 4544] [serial = 47] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA.html]
09:51:08     INFO - GECKO(6612) | --DOMWINDOW == 11 (000001A667B99000) [pid = 4544] [serial = 50] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA1.html]
09:51:12     INFO - GECKO(6612) | --DOMWINDOW == 10 (000001A6689B6800) [pid = 4544] [serial = 51] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA1.html]
09:51:12     INFO - GECKO(6612) | --DOMWINDOW == 9 (000001A6614F5800) [pid = 4544] [serial = 48] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA.html]
09:51:12     INFO - GECKO(6612) | --DOMWINDOW == 8 (000001A6678B3000) [pid = 4544] [serial = 49] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageC.html]
09:51:12     INFO - GECKO(6612) | --DOMWINDOW == 7 (000001A6614E9000) [pid = 4544] [serial = 52] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
09:51:12     INFO - GECKO(6612) | --DOMWINDOW == 6 (000001A65C1CD000) [pid = 4544] [serial = 45] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/test_bug1028200-7.html]
09:51:20     INFO - GECKO(6612) | [Parent 6612, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/dom/fetch/FetchDriver.cpp, line 417
09:52:32     INFO - GECKO(6612) | [Parent 6612, Lazy Idle] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/widget/windows/WinUtils.cpp, line 1490
09:54:32     INFO - GECKO(6612) | [Parent 6612, Lazy Idle] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/widget/windows/WinUtils.cpp, line 1490
09:56:03     INFO - TEST-INFO | started process screenshot
09:56:03     INFO - TEST-INFO | screenshot: exit 0
09:56:03     INFO - TEST-UNEXPECTED-FAIL | dom/plugins/test/mochitest/test_bug1092842.html | Test timed out. 
09:56:03     INFO -     reportError@SimpleTest/TestRunner.js:121:7
09:56:03     INFO -     TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     setTimeout handler*TestRunner._checkForHangs@SimpleTest/TestRunner.js:163:5
09:56:03     INFO -     TestRunner.runTests@SimpleTest/TestRunner.js:380:5
09:56:03     INFO -     RunSet.runtests@SimpleTest/setup.js:194:3
09:56:03     INFO -     RunSet.runall@SimpleTest/setup.js:173:5
09:56:03     INFO -     hookupTests@SimpleTest/setup.js:266:5
09:56:03     INFO - parseTestManifest@http://mochi.test:8888/manifestLibrary.js:36:5
09:56:03     INFO - getTestManifest/req.onload@http://mochi.test:8888/manifestLibrary.js:49:11
09:56:03     INFO - EventHandlerNonNull*getTestManifest@http://mochi.test:8888/manifestLibrary.js:45:3
09:56:03     INFO -     hookup@SimpleTest/setup.js:246:5
09:56:03     INFO - EventHandlerNonNull*@http://mochi.test:8888/tests?autorun=1&closeWhenDone=1&consoleLevel=INFO&manifestFile=tests.json&dumpOutputDirectory=c%3A%5Cusers%5Ccltbld%5Cappdata%5Clocal%5Ctemp&cleanupCrashes=true:11:1
09:56:04     INFO - GECKO(6612) | MEMORY STAT | vsize 1606MB | vsizeMaxContiguous 131424223MB | residentFast 29MB | heapAllocated 26MB
this started failing on oct 13th on win10 in the clipboard job (this runs on hardware, we have had no changes on the hardware platform in a while, especially the last week).  We have 72 failures right now, almost all on debug- most of stylo-disabled.

here is a recent log file:
https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=137832473

here is the related screenshot (not a lot of info):
https://mozilla-releng-blobs.s3.amazonaws.com/blobs/mozilla-inbound/sha512/319009ea93af716283956f4b60240e30c1e8e91f0b8884984a2e6a0b852388ce0e64b29c8fb8e35cc1021561bd960c480c8dcce53cdf284c28d7897cec7eeff6

and a clip from the above log:
02:50:13     INFO - TEST-START | dom/plugins/test/mochitest/test_bug1092842.html
02:50:13     INFO - GECKO(5156) | ++DOMWINDOW == 19 (0000025C7D279000) [pid = 9144] [serial = 53] [outer = 0000025C7D6D7000]
02:50:13     INFO - GECKO(5156) | [Child 9144, Main Thread] WARNING: stylo: Web Components not supported yet: file z:/build/build/src/dom/base/nsDocument.cpp, line 6455
02:50:13     INFO - GECKO(5156) | [Child 9144, Main Thread] WARNING: stylo: Web Components not supported yet: file z:/build/build/src/dom/base/nsDocument.cpp, line 6455
02:50:13     INFO - GECKO(5156) | For application/x-test found plugin nptest.dll
02:50:13     INFO - GECKO(5156) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\users\cltbld\appdata\local\temp\tmpd2yfrm.mozrunner\runtests_leaks_plugin_pid6856.log
02:50:13     INFO - GECKO(5156) | [NPAPI 6856, Main Thread] WARNING: NS_ENSURE_TRUE(InitStaticMembers()) failed: file z:/build/build/src/modules/libpref/Preferences.cpp, line 4964
02:50:13     INFO - GECKO(5156) | [NPAPI 6856, Main Thread] WARNING: '!mInitialized', file z:/build/build/src/xpcom/threads/nsThreadManager.cpp, line 350
02:50:13     INFO - GECKO(5156) | [NPAPI 6856, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/xpcom/threads/nsThreadUtils.cpp, line 150
02:50:13     INFO - GECKO(5156) | --DOCSHELL 0000025C7C78B800 == 5 [pid = 9144] [id = {c61724a2-c415-43a7-b041-275b51bf665b}]
02:50:13     INFO - GECKO(5156) | --DOCSHELL 0000025C76521000 == 4 [pid = 9144] [id = {78c35ad6-b051-478b-9f39-d9da60a445c8}]
02:50:13     INFO - GECKO(5156) | --DOCSHELL 0000025C00395800 == 3 [pid = 9144] [id = {63028529-fe68-4692-8d0d-c62ed17d4fc0}]
02:50:16     INFO - GECKO(5156) | --DOMWINDOW == 18 (0000025C7F88E000) [pid = 9144] [serial = 40] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
02:50:16     INFO - GECKO(5156) | --DOMWINDOW == 17 (0000025C7D27B000) [pid = 9144] [serial = 42] [outer = 0000000000000000] [url = about:blank]
02:50:17     INFO - GECKO(5156) | --DOMWINDOW == 16 (0000025C0038A800) [pid = 9144] [serial = 44] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
02:50:17     INFO - GECKO(5156) | --DOMWINDOW == 15 (0000025C7C781000) [pid = 9144] [serial = 41] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/test_bug1028200-6.html]
02:50:17     INFO - GECKO(5156) | --DOMWINDOW == 14 (0000025C7D27C800) [pid = 9144] [serial = 43] [outer = 0000000000000000] [url = about:blank]
02:50:23     INFO - GECKO(5156) | --DOMWINDOW == 13 (0000025C7651D800) [pid = 9144] [serial = 46] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageC.html]
02:50:23     INFO - GECKO(5156) | --DOMWINDOW == 12 (0000025C76523000) [pid = 9144] [serial = 47] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA.html]
02:50:23     INFO - GECKO(5156) | --DOMWINDOW == 11 (0000025C7C78C000) [pid = 9144] [serial = 50] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA1.html]
02:50:27     INFO - GECKO(5156) | --DOMWINDOW == 10 (0000025C7C485800) [pid = 9144] [serial = 49] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageC.html]
02:50:27     INFO - GECKO(5156) | --DOMWINDOW == 9 (0000025C7D286000) [pid = 9144] [serial = 52] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
02:50:27     INFO - GECKO(5156) | --DOMWINDOW == 8 (0000025C00389800) [pid = 9144] [serial = 48] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA.html]
02:50:27     INFO - GECKO(5156) | --DOMWINDOW == 7 (0000025C00381000) [pid = 9144] [serial = 45] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/test_bug1028200-7.html]
02:50:27     INFO - GECKO(5156) | --DOMWINDOW == 6 (0000025C7C794000) [pid = 9144] [serial = 51] [outer = 0000000000000000] [url = http://mochi.test:8888/tests/dom/plugins/test/mochitest/1028200-subpageA1.html]
02:50:33     INFO - GECKO(5156) | [Parent 5156, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/dom/fetch/FetchDriver.cpp, line 417
02:51:45     INFO - GECKO(5156) | [Parent 5156, Lazy Idle] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/widget/windows/WinUtils.cpp, line 1490
02:53:45     INFO - GECKO(5156) | [Parent 5156, Lazy Idle] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/widget/windows/WinUtils.cpp, line 1490
02:55:17     INFO - TEST-INFO | started process screenshot
02:55:17     INFO - TEST-INFO | screenshot: exit 0
02:55:17     INFO - TEST-UNEXPECTED-FAIL | dom/plugins/test/mochitest/test_bug1092842.html | Test timed out. 
02:55:17     INFO -     reportError@SimpleTest/TestRunner.js:121:7



I did some retriggers when this first started:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=win%20x64%20clipboard%20debug%20stylo&tochange=41e3ae0e04b1bcf94520145618ecc279195d8900&fromchange=933be59f89bdd36a320527bc29b44566bae9ad3b&selectedJob=136826425

I am still waiting for results- possibly this will tell us what the root cause is.


:jimm, I see you are the triage owner for plug-ins, can you help determine the priority of this and get this in queue to be worked on when appropriate?
Flags: needinfo?(jmathies)
Whiteboard: [stockwell needswork]
See Also: → 1408703
See Also: → 1408704
this is converging on bug 1391262, I did a few more retriggers to verify that.
:sotoro, I see you authored the patches in bug 1391262, they appear to be causing a lot of plugin tests to be failing on windows 10 quite frequently (look at this bug and the two other intermittent bugs in the see also section) - can you take a look at this?
Blocks: 1391262
Component: Plug-ins → Graphics: WebRender
Flags: needinfo?(jmathies) → needinfo?(sotaro.ikeda.g)
I take a look.
Assignee: nobody → sotaro.ikeda.g
Flags: needinfo?(sotaro.ikeda.g)
From the log, when the problem happened, client side seemed to use BasicLayerManager because layers are not connected.
Status: NEW → ASSIGNED
Priority: P5 → P1
Whiteboard: [stockwell needswork] → [wr-mvp] [stockwell needswork]
During looking into the log, I found another problem. I created Bug 1410766 for it.
See Also: → 1410766
From the log, verifyLayersRendering() seemed to fail often on the "Windows 10 x64" machine. If it fails, triggerDeviceReset() is called.
  https://dxr.mozilla.org/mozilla-central/source/toolkit/components/gfx/SanityTest.js#142

triggerDeviceReset() triggers to re-generate CompositorBridgeParent and LayerTransactionChild re-creation. This re-creation seems to related to the test time out problem.
When I change SanityTest.js as always to fail at verifyLayersRendering(), I sometimes saw that test_bug1092842.html does not end with "./mach test dom/plugins/test/mochitest/test_bug1092842.html". When it happened, TabChild::InitRenderingState() failed to create remote LayerManager because of triggerDeviceReset(). If the InitRenderingState() caused to fallback to BasicLayerManager, TabChild::ReinitRenderingForDeviceReset() did not trigger re-creating remote LayerManager.
attachment 8922303 [details] [diff] [review] changed TabChild::ReinitRenderingForDeviceReset() as to call ReinitRendering(), even when TabChild::InitRenderingState() failed to create remote LayerManager.
Attachment #8922303 - Attachment is obsolete: true
Attachment #8922626 - Flags: review?(dvander)
Comment on attachment 8922626 [details] [diff] [review]
patch - Fix reinitRendering for deviceReset

Review of attachment 8922626 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/ipc/TabChild.cpp
@@ +2951,5 @@
>      {
>        success = true;
>      }
>      if (!success) {
> +      if (shadowManager) {

Can you explain why this part is necessary? It doesn't look like it should be, but maybe I'm missing something.
(In reply to David Anderson [:dvander] from comment #19)
> Comment on attachment 8922626 [details] [diff] [review]
> patch - Fix reinitRendering for deviceReset
> 
> Review of attachment 8922626 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: dom/ipc/TabChild.cpp
> @@ +2951,5 @@
> >      {
> >        success = true;
> >      }
> >      if (!success) {
> > +      if (shadowManager) {
> 
> Can you explain why this part is necessary? It doesn't look like it should
> be, but maybe I'm missing something.

If is necessary to destroy PLayerTransactionChild. When shadowManager->SendGetTextureFactoryIdentifier() failed and PLayerTransactionChild was created, PLayerTransactionChild was not destroyed. Then if TabChild::ReinitRenderingForDeviceReset() was called, CompositorBridgeParent::RecvNotifyChildRecreated() was failed, because layersId was not yet removed from sIndirectLayerTrees.

When shadowManager->SendGetTextureFactoryIdentifier() succeeded and mPuppetWidget->CreateRemoteLayerManager() failed, PLayerTransactionChild was removed automatically as part of LayerManager destruction.
(In reply to Sotaro Ikeda [:sotaro] from comment #20)
> 
> If is necessary to destroy PLayerTransactionChild.

Correction:
 It is necessary to destroy PLayerTransactionChild.
(In reply to Sotaro Ikeda [:sotaro] from comment #20)
> 
> If is necessary to destroy PLayerTransactionChild. When
> shadowManager->SendGetTextureFactoryIdentifier() failed and
> PLayerTransactionChild was created, PLayerTransactionChild was not
> destroyed.

It could typically happen when "mTextureFactoryIdentifier.mParentBackend == LayersBackend::LAYERS_NONE".
It looks like there is a potential fix here, I will wait a day or two before disabling this test.
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d17acfc5ee3
Disable dom/plugins/test/mochitest/test_bug1092842.html on windows debug for frequent failures. r=me, a=testonly
I disabled this test for having >200 failures in the last 30 days, please remember to enable this when testing a fix
Keywords: leave-open
Whiteboard: [wr-mvp] [stockwell disable-recommended] → [wr-mvp] [stockwell disabled]
Comment on attachment 8922626 [details] [diff] [review]
patch - Fix reinitRendering for deviceReset

Review of attachment 8922626 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/ipc/TabChild.cpp
@@ +2952,5 @@
>        success = true;
>      }
>      if (!success) {
> +      if (shadowManager) {
> +        static_cast<LayerTransactionChild*>(shadowManager)->Destroy();

(In reply to Sotaro Ikeda [:sotaro] from comment #22)

Okay, thanks: so to be clear, it's not that "SendGetTextureFactoryIdentifier" is failing (that would indicate an IPC problem), but that the host layer manager is gone so it returns LAYERS_NONE. Then, because we never created a ClientLayerManager, we never shut down the old PLayerTransaction when we handle the device reset.

This fix seems fine, but please include a comment like this above:

// Since no LayerManager is associated with the tab's widget, we will never
// have an opportunity to destroy the PLayerTransaction on the next device
// or compositor reset. Therefore, we make sure to forcefully close it here.
// Failure to do so will cause the next layer tree to fail to attach due
// since the compositor requires the old layer tree to be disassociated.
Attachment #8922626 - Flags: review?(dvander) → review+
Attachment #8922626 - Attachment is obsolete: true
Attachment #8924041 - Flags: review+
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/03a5eae858e7
Fix reinitRendering for deviceReset r=dvander
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fc976813529e6c56d42960d06011b0434c8245bc

With attachment 8924413 [details] [diff] [review], "dom/plugins/test/mochitest/test_bug1092842.html | Test timed out" seemed not happen.
Attachment #8924413 - Flags: review?(jmaher)
Comment on attachment 8924413 [details] [diff] [review]
patch - Re-enable dom/plugins/test/mochitest/test_bug1092842.html

Review of attachment 8924413 [details] [diff] [review]:
-----------------------------------------------------------------

awesome
Attachment #8924413 - Flags: review?(jmaher) → review+
Whiteboard: [wr-mvp] [stockwell disabled] → [wr-mvp] [stockwell fixed:product]
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f7b7b510805e
Re-enable dom/plugins/test/mochitest/test_bug1092842.html r=jmaher
https://hg.mozilla.org/mozilla-central/rev/f7b7b510805e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
So generally if patches have landed on a bug (specially in a case like this where they landed a while ago) we prefer that you file a new bug instead of reopening. Otherwise it gets very confusing to track. Would you mind using the bugfiler interface to file a new bug for the failure? That will also insert a link to the logview page which is useful. I can do it tomorrow when I'm at a computer if you don't get to it before then. Thanks!
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Flags: needinfo?(csabou)
Resolution: --- → FIXED
Ok Kartikaya, will file a new bug and will do so in the future for these kind of cases.
Thanks for the explanations.
Flags: needinfo?(csabou)
See Also: → 1423458
You need to log in before you can comment on or make changes to this bug.