Closed Bug 1408567 Opened 3 years ago Closed 3 years ago

Require rust 1.20.

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set
normal

Tracking

(firefox58 fixed)

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: rillian, Assigned: rillian)

References

Details

Attachments

(1 file)

Require at least rust 1.20.0 to build firefox, now that we have 1.20 working in official builds and it's been more than the scheduled 2 weeks past release.
Comment on attachment 8918471 [details]
Bug 1408567 - Require Rust 1.20.0 or newer.

https://reviewboard.mozilla.org/r/189316/#review194616

On IRC, rillian tells me that bumping the toolchains in the -base-toolchains build task will verify that we still build with the minimum.  So lgtm!
Attachment #8918471 - Flags: review+
Attachment #8918471 - Flags: review?(core-build-config-reviews)
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8879a995468d
Require Rust 1.20.0 or newer. r=nalexander
https://hg.mozilla.org/mozilla-central/rev/8879a995468d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7be864a6cef7
Port bug 1408567 - Require Rust 1.20.0 or newer - Rust details from M-C rev 6f1782b58101. rs=bustage-fix
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.