Closed Bug 1408613 Opened 2 years ago Closed 2 years ago

Fix visibility of PanelUI-panic-timeframe-icon

Categories

(Firefox :: Toolbars and Customization, defect, P4)

defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox56 --- unaffected
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: magicp.jp, Assigned: Gijs)

References

Details

Attachments

(4 files)

Steps to Reproduce:
1. Start Nightly
2. Add Forget button to Toolbar
3. Open Forget panel
4. Pin Forget button to Overflow Menu
5. Open Forget panel

Actual Results:
In step 3, #PanelUI-panic-timeframe-icon is invisible.
In step 5, #PanelUI-panic-timeframe-icon is visible while opening panel. (duplicate to small icon)

Expected Results:
In step 3, #PanelUI-panic-timeframe-icon is visible.
In step 5, #PanelUI-panic-timeframe-icon is hidden even if while opening panel.
Priority: -- → P4
See Also: → 1408390
#PanelUI-panic-timeframe-icon and #PanelUI-panic-timeframe-icon-small visibility will be controled by #PanelUI-panicView current attribute and #PanelUI-panicView cui-widget-panelview class. But, current attribute doesn't work correctly after Bug 1401991. And also cui-widget-panelview class is not matched in photon panel. I think that #PanelUI-panic-timeframe-icon is always visible, and #PanelUI-panic-timeframe-icon-small is invisible in photon panel.
Blocks: 1401991
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Duplicate of this bug: 1408390
Comment on attachment 8926452 [details]
Bug 1408613 - stop trying to use a smaller image in the overflow panel which is wide enough,

https://reviewboard.mozilla.org/r/197700/#review202934

Looks great, thanks!
Attachment #8926452 - Flags: review?(mdeboer) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7e2fd1290064
stop trying to use a smaller image in the overflow panel which is wide enough, r=mikedeboer
https://hg.mozilla.org/mozilla-central/rev/7e2fd1290064
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
I have reproduced this bug with Nightly 58.0a1 (2017-10-13) on Windows 10, 64 Bit!

This bug's fix is verified with latest Beta!

Build ID   : 20171204150510
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
QA Whiteboard: [bugday-20171213]
You need to log in before you can comment on or make changes to this bug.