Closed Bug 1408957 Opened 2 years ago Closed 2 years ago

netwerk/protocol/device/ seems to be dead code

Categories

(Core :: Networking, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

Schien said in https://bugzilla.mozilla.org/show_bug.cgi?id=1408751#c2 that the device directory is probably useless.
Reporting a bug to make sure it doesn't get lost.

The code coverage confirms that no test uses this code path:
https://codecov.io/gh/marco-c/gecko-dev/tree/master/netwerk/protocol/device
Assignee: nobody → sledru
Priority: -- → P2
Whiteboard: [necko-triaged]
Dragana, who do you think should sign off on that? Thanks
Flags: needinfo?(dd.mozilla)
I do not see any use of 'moz-device' protocol in the code.

To be completely sure let's ask bz to confirm.

bz, do we use 'moz-device', i.e. nsDeviceChannel somewhere in dom? I see only GetUserMedia api.

I could review the code.
Flags: needinfo?(dd.mozilla) → needinfo?(bzbarsky)
This is the first time I've seen this code, so not sure how much use I'll be... but there seem to be no hits for either nsDeviceChannel or "moz-device:" anywhere.  And it's never been web-exposed.  So I think it's fine to remove.
Flags: needinfo?(bzbarsky)
Attachment #8918813 - Flags: review?(dd.mozilla)
Comment on attachment 8918813 [details]
Bug 1408957 - Remove netwerk/protocol/device/ (no longer used)

https://reviewboard.mozilla.org/r/189662/#review195294

thanks.
Attachment #8918813 - Flags: review?(dd.mozilla) → review+
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55172a4afa4a
Remove netwerk/protocol/device/ (no longer used) r=dragana
Duplicate of this bug: 1130322
Blocks: 1409391
https://hg.mozilla.org/mozilla-central/rev/55172a4afa4a
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Depends on: 1410993
You need to log in before you can comment on or make changes to this bug.