Closed Bug 1409051 Opened 4 years ago Closed 9 months ago

Lots of frames dropped when e10s is on

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jya, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regressionwindow-wanted, Whiteboard: [gfx-noted])

When playing any 60fps videos on YouTube, we can see a fair amount of frames being dropped.
It's even more obvious with high resolution videos. 


Turning off e10s fixes the issue.
This is unlikely to be decoder related, as the decoder code path is common between the two. 


Note that disabling the Gpu process (or the Gpu remote decoder) doesn't fix the problem. Only disabling e10s completely does.

This is a recent regression, I didn't experience those issues a couple of month back.
Disabling advanced layers doesn't make a difference so it's not that either.
The frames are dropped in the compositor, as we don't see the number of frames dropped changing in the VideoPlaybackQuality attribute. (bug 1245400)
See Also: → 1407351
For the bug related to e10s, like[1], it could be the same cause, since both Jya and I can see this problem on our 4k panel.  

[1]https://bugzilla.mozilla.org/show_bug.cgi?id=1383292#c18
See Also: → 1383292
See Also: → 1411854
Per comment 1, it looks like a gfx bug. Add the keyword in the whiteboard.
Whiteboard: [gfx-noted]
(In reply to Jean-Yves Avenard [:jya] from comment #0)
> This is a recent regression, I didn't experience those issues a couple of
> month back.
> Disabling advanced layers doesn't make a difference so it's not that either.

Have you tried bisecting?
See Also: → 1404042
Here is a stream where it's easy to test:

go to about:config
set
media.mediasource.webm.enabled to true

Open:
https://www.youtube.com/watch?v=R3AKlscrjmQ

Switch to full screen, and select the 2160p/60fps stream.

Result on my 2013 mac Pro (8 cores, 32GB of RAM):
e10s you see about 1/3rd of the frames being dropped
with e10s off, it's smooth as butter

Note that we do not report frames dropped by the compositor, so YouTube "stats for nerds" right click on the player window and select that, will show 0 frames being dropped.

But you can visually see them being dropped.
(In reply to Marco Castelluccio [:marco] from comment #4)
> (In reply to Jean-Yves Avenard [:jya] from comment #0)
> > This is a recent regression, I didn't experience those issues a couple of
> > month back.
> > Disabling advanced layers doesn't make a difference so it's not that either.
> 
> Have you tried bisecting?

I'll tried...

bisecting with e10s on/off is a pain however.. the pref name changing over time, the method to disabling it changing etc.
(In reply to Jean-Yves Avenard [:jya] from comment #5)
> Here is a stream where it's easy to test:
> 
> go to about:config
> set
> media.mediasource.webm.enabled to true
> 
> Open:
> https://www.youtube.com/watch?v=R3AKlscrjmQ
> 
> Switch to full screen, and select the 2160p/60fps stream.
> 
> Result on my 2013 mac Pro (8 cores, 32GB of RAM):
> e10s you see about 1/3rd of the frames being dropped
> with e10s off, it's smooth as butter

Weird... I re-ran it and with e10s on in nightly it was perfect all of a sudden....
See Also: → 1489659

Marking this ticket as resolved as per comment 7 . Please feel free to reopen this bug if you have any troubles.

Regards, Clara

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.