Update adb for Android emulator tests

RESOLVED FIXED in Firefox 58

Status

()

enhancement
RESOLVED FIXED
2 years ago
4 months ago

People

(Reporter: gbrown, Assigned: gbrown)

Tracking

Trunk
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 fixed)

Details

Attachments

(1 attachment)

Our Android emulator unit test environment uses a very old version of adb -- adb 1.0.31. That may be causing trouble for bug 1404525; even if it isn't, it seems like it should be updated, so there's less difference with the typical development environment.
See Also: → 1285678
Comment on attachment 8919073 [details] [diff] [review]
update emulator unit test configuration for new android sdk download with new adb

Review of attachment 8919073 [details] [diff] [review]:
-----------------------------------------------------------------

a big step for robotkind
Attachment #8919073 - Flags: review?(jmaher) → review+
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/137fa515a573
Use new tooltool download for android sdk in emulator unit tests; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/137fa515a573
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
See Also: → 1410723
See Also: → 1534737
You need to log in before you can comment on or make changes to this bug.