Closed Bug 1409366 Opened 3 years ago Closed 10 months ago

[Form Autofill] Credit card expiration Year is placed above the payment section when using autofill on "homedepot.com"

Categories

(Web Compatibility :: Desktop, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Gabi, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [form autofill])

Attachments

(1 file)

Attached image yearplacement.png
[Affected versions]:
- latest Nightly 58.0a1

[Affected platforms]:
- macOS 10.12.6
- Windows 10 64 bit
- Ubuntu 14.04 32bit

[Steps to reproduce]:
1. Start Firefox
2. Create a Credit Card profile from about:preferences#privacy
3. Visit homedepot.com and login with a test account
4. Proceed to checkout 
5. Double click on Credit Card fields to trigger autofill
6. Select credit card profile
7. Observe the expiration year placement on the page

[Expected result]:
- Year should be displayed within the payment information section

[Actual result]:
- Expiration year is placed above the payment information section 

[Regression range]:
- Not sure if this is a regression, will investigate further asap.

[Additional notes]:
- Screenshot of the issue is attached.
No longer depends on: 1385788
There are two sets of cc-exp* are detected in the page:
<input name="expiryMonth" autocomplete="cc-exp-month">
<input name="expiryYear" autocomplete="cc-exp-year">
<select id="ccMonth">
<select id="ccYear">

The two <input> fields are with `autocomplete` attr and should be invisible, but homedepot does not hide them or make it invisible when it contains a value.

AFAIK, Chrome has the same issue here.
Priority: -- → P3
According to comment 2, it should be a webcompact issue as they do have inputs placed there and mark them as the expiry-date-related fields by @autocomplete. We have no choice but to respect it. Since it's unlikely to be fixed by Form Autofill, move it to Tech Evangelism.
Component: Form Manager → Desktop
Priority: P3 → --
Product: Toolkit → Tech Evangelism
Summary: [Form Autofill] - Credit card expiration Year is placed above the payment section when using autofill → [Form Autofill] Credit card expiration Year is placed above the payment section when using autofill on "homedepot.com"
Whiteboard: [form autofill:MVP] → [form autofill]
Priority: -- → P3
Product: Tech Evangelism → Web Compatibility

(In reply to Sean Lee [:seanlee][:weilonge] from comment #2)

The two <input> fields are with autocomplete attr and should be invisible,
but homedepot does not hide them or make it invisible when it contains a
value.

AFAIK, Chrome has the same issue here.

not a webcompat issue, just a badly designed website if it is still there.
feel free to contact them. Closing as wontfix.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.