Closed Bug 1409395 Opened 2 years ago Closed 2 years ago

After update to nightly 20171017100127, impossible to open usual profile

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- verified

People

(Reporter: clement.lefevre, Assigned: Felipe)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [mozfr-community])

Attachments

(3 files)

Attached image Broken nightly look
With 20171017100127 update, opening usual profile is resulting in a totally broken Nightly. Opened tabs have disappear, hamburger menu is broken, everything looks kinda unusable. See the joined screenshot to see how does it look.

Creating a clean profile make it behave correctly though.
Whiteboard: [mozfr-community]
:RyanVM working on the regression window right now.
Updates blocked as of now to avoid more affected users.
Problem reproduced by different people on macOS with 10.9 and 10.13 at least.
Updates were not yet available on Linux and Windows to see if those were affected either.
It affects Windows too.

INFO: Last good revision: 3d7a9563f96605c1dce7f8640a5b7e963b32497c
INFO: First bad revision: e6ee25ad6a9fbd6567b0ec1723d18f670eed3a2c
INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3d7a9563f96605c1dce7f8640a5b7e963b32497c&tochange=e6ee25ad6a9fbd6567b0ec1723d18f670eed3a2c

Let's get bug 1407351 backed out ASAP.
Blocks: 1407351
Has Regression Range: --- → yes
This affects Linux also.  My Android builds that I built from the same source under Linux appear unaffected.  My windows build is still in progress.
Bug 1407351 backed out. I'll respin nightlies as well.

https://hg.mozilla.org/mozilla-central/rev/f27105b62753c71ecadad2f8d632ec7e5ac96bbd
Assignee: nobody → felipc
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Clément, are you able to get any (error) messages from the console with this broken build? If the console doesn't open, you might be able to get some info when you start the firefox binary from the command line in a Terminal window.
Flags: needinfo?(clement.lefevre)
(In reply to Mike de Boer [:mikedeboer] from comment #6)
> Clément, are you able to get any (error) messages from the console with this
> broken build? If the console doesn't open, you might be able to get some
> info when you start the firefox binary from the command line in a Terminal
> window.

No, terminal doesn't show anything useful), and UI is totally unusable, everything is broken into it.
As promised this is terminal output from running my Linux 64-bit build.
Thanks, Bill! That's super helpful.
Flags: needinfo?(clement.lefevre)
mozregression showed the following stdout on a Windows opt build:
INFO: IPDL protocol error: [PNeckoChild] Received an invalid file descriptor!
INFO: IPDL protocol error: [PNeckoChild] Received an invalid file descriptor!

That's all there was. No clue if it's relevant or not.
Fwiw, I dropped all updates from nightly -latest blob in Balrog. And then re-enabled updates.

what this means specifically is that as soon as the new updates from this backout finish, users will get them, but won't get an update until then.

I used the minimal blob Nick wrote in https://bugzilla.mozilla.org/show_bug.cgi?id=1404016
Duplicate of this bug: 1409414
Duplicate of this bug: 1409412
Duplicate of this bug: 1409376
I've noticed a couple of interesting things about this. First, Nightly sometimes has a really hard time shutting down. Firefox will utilize all my cores for about 30 seconds, and then I will get cpu temperature warnings in my journal.

I also see this line:
Oct 17 16:27:49 mikehenrty-arch gvfsd[690]: got no contact to IPC$

Running Nightly from command line produces nothing in the terminal window for me.
I am unable to duplicate this issue with my WIndows 64-bit build.  SO, it would seem to be Mac and Linux only.
It affects Windows, as I said in comment 3.
(In reply to Ryan VanderMeulen [:RyanVM] from comment #17)
> It affects Windows, as I said in comment 3.

Must be something different about my Windows profile then.
Duplicate of this bug: 1409123
I just updated on my other GNU/Linux machine and it works fine. I did it for 2 builds with 2 different locales (English and Romanian). Same profile for both. No issue.

I think I might know what happened on my other machine. I had a Firefox ESR v52 running and maybe after the Nightly update, the profile was opened with ESR instead of Nightly. I know there are some incompatibilities between versions pre54 and postv54. I opened the profile in Firefox ESR and it worked fine. It was still messed up in Nightly.
I'm confirming that bug is fixed, starting in latest Mozilla Firefox Nightly 58.0a1 (2017-10-17)
[Built from https://hg.mozilla.org/mozilla-central/rev/f27105b62753c71ecadad2f8d632ec7e5ac96bbd],
so I'm marking this bug as VERIFIED.
Thank you very much! \o/
Status: RESOLVED → VERIFIED
QA Contact: Virtual
You need to log in before you can comment on or make changes to this bug.