Closed Bug 1410512 Opened 5 years ago Closed 3 years ago

Add support for getting nightly, beta and release partials for Thunderbird.

Categories

(Thunderbird :: Build Config, enhancement, P3)

enhancement

Tracking

(thunderbird_esr68 fixed, thunderbird74 fixed)

RESOLVED FIXED
Thunderbird 75.0
Tracking Status
thunderbird_esr68 --- fixed
thunderbird74 --- fixed

People

(Reporter: tomprince, Assigned: rjl)

References

Details

Attachments

(4 files, 5 obsolete files)

Assignee: mozilla → nobody
Duplicate of this bug: 1222693
Priority: P5 → P3
Summary: Add support for getting nightly partials for Thunderbird. → Add support for getting nightly, beta and release partials for Thunderbird.
Attached patch partial_updates.patch (obsolete) — Splinter Review
WIP.
THough it does seem to be working as it produced a few files:
http://ftp.stage.mozaws.net/pub/thunderbird/nightly/partials/2020/02/2020-02-04-02-25-07-try-comm-central/
Assignee: nobody → rob
Status: NEW → ASSIGNED
Attached patch partial_updates_part_2.patch (obsolete) — Splinter Review
For partial updates the parameters to the decision task need to include
release history.
Requires D61636 from bug 1609987.
Attached patch partial_updates.patch (obsolete) — Splinter Review
Set up the tasks for creating partial updates. This patch alone won't do
anything.
Attachment #9124585 - Flags: review?(geoff)
Attachment #9124185 - Attachment is obsolete: true
Attached patch partial_updates_part_2.patch (obsolete) — Splinter Review
Requires D61636 on M-C; that's currently on autoland.
Uses the same function as Firefox to get the recent release history from
Balrog.
Attachment #9124587 - Flags: review?(geoff)
Attachment #9124386 - Attachment is obsolete: true
Comment on attachment 9124585 [details] [diff] [review]
partial_updates.patch

Review of attachment 9124585 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.

::: taskcluster/ci/partials/kind.yml
@@ +28,5 @@
> +    - win32-nightly/opt
> +    - win64-shippable/opt
> +    - win64-nightly/opt
> +
> +

Extra empty line.
Attachment #9124585 - Flags: review?(geoff) → review+
Comment on attachment 9124587 [details] [diff] [review]
partial_updates_part_2.patch

Review of attachment 9124587 [details] [diff] [review]:
-----------------------------------------------------------------

::: taskcluster/comm_taskgraph/__init__.py
@@ +41,5 @@
> +
> +    parameters.setdefault('release_history', dict())
> +    if 'nightly' in parameters.get('target_tasks_method', ''):
> +        parameters['release_history'] = populate_release_history(BALROG_PRODUCT,
> +                                                                 project)

You've got 99 characters to work with in Python, no need for this ugly wrapping. :/
Attachment #9124587 - Flags: review?(geoff) → review+
Attachment #9124585 - Attachment is obsolete: true
Attached patch partial_updates_part_2.patch (obsolete) — Splinter Review
Attachment #9124587 - Attachment is obsolete: true
Attachment #9124867 - Attachment is obsolete: true

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/fbdc28c1011c
Build partial update MARs for Thunderbird. r=darktrojan
https://hg.mozilla.org/comm-central/rev/010e3872fa13
Include release history on nightly builds. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I need to look into getting a cache set up for Thunderbird, if it's necessary
at all. I will update this bug with findings. In the meantime, we can at least
build and test the updates themselves.
Attachment #9125158 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9125158 [details] [diff] [review]
partial_updates_part_3.patch

Review of attachment 9125158 [details] [diff] [review]:
-----------------------------------------------------------------

rs=mkmelin
Attachment #9125158 - Flags: review?(mkmelin+mozilla) → review+
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/edd42b546bfe
Follow-up: Disable mbsdiff cache when building partial updates. rs=mkmelin

As far as the cache goes, it's not necessary. It may save some time when promoting a release, so I can watch the build times and go from there.

Partials generated this morning.

Verified working on:

  • Linux - Walt
  • macOS - Rob
  • Win64 - Rob
Comment on attachment 9124866 [details] [diff] [review]
partial_updates.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #9124866 - Flags: approval-comm-esr68?
Attachment #9124866 - Flags: approval-comm-esr68?
Attachment #9125158 - Flags: approval-comm-esr68?

[Approval Request Comment]
We an get partials comm-esr68 without having to make modifications to mozilla-esr68.
Only these two commits are needed:
https://hg.mozilla.org/comm-central/rev/fbdc28c1011c
https://hg.mozilla.org/comm-central/rev/edd42b546bfe

The reason for not needing the Mozilla changes and rev 010e3872fa13: The Mozilla code changes are only necessary to generate the partial updates for Nightly. That line of code is not needed when generating partials for a release build because the versions to build partials for are entered by the release manager when the release is promoted in Ship-It whereas for Nightly releases they are determined automatically based on what's in Balrog.

The remaining commits needed some minor changes to work on c-esr68, so this attachment should be applied directly.

Attachment #9130571 - Flags: approval-comm-esr68?
Comment on attachment 9130571 [details] [diff] [review]
comm-esr68_partials_combined_uplift.patch

We'll test this during smoketesting.
Attachment #9130571 - Flags: approval-comm-esr68? → approval-comm-esr68+
Target Milestone: --- → Thunderbird 75.0
You need to log in before you can comment on or make changes to this bug.