Remove unused PanelUI-popup code

RESOLVED FIXED in Firefox 58

Status

()

enhancement
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ntim, Assigned: jaws)

Tracking

(Blocks 1 bug)

unspecified
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 fixed)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

2 years ago
Old panel code has been removed in bug 1354117.
Reporter

Updated

2 years ago
Summary: Remove unused CSS from panelUI.inc.css → Remove unused PanelUI-popup code
Reporter

Updated

2 years ago
Assignee: ntim.bugs → nobody
Reporter

Comment 1

2 years ago
Posted patch WIP-PanelUI.patch (obsolete) — Splinter Review
I've attached a WIP.

I'm not planning to work on this further, so feel free to steal this.

Here's what's left to do:
- Removing more strings
- Fixing the bookmarks menu checkmark
- Looking if there's more stuff to remove
Whiteboard: [photon-structure][triage]
Priority: -- → P4
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Reporter

Updated

2 years ago
See Also: → 1413247
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
Priority: P4 → P1
Comment hidden (mozreview-request)

Comment 4

2 years ago
mozreview-review
Comment on attachment 8923924 [details]
Bug 1410666 - Remove unused PanelUI-popup code.

https://reviewboard.mozilla.org/r/195084/#review200634

Phew, that was hard to review. :)

I think it seems okay - one (maybe) alignment issue, but otherwise seems good. Thanks!

::: browser/components/customizableui/content/panelUI.inc.xul:355
(Diff revision 2)
>                         key="key_quitApplication"
>                         command="cmd_quitApplication"/>
>  #endif
>        </vbox>
>      </panelview>
> +        <panelview id="PanelUI-history" flex="1">

Is the alignment here busted, or is MozReview confusing me?
Attachment #8923924 - Flags: review?(mconley) → review+
Comment hidden (mozreview-request)

Comment 6

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b558ad2372bf
Remove unused PanelUI-popup code. r=mconley
Comment hidden (mozreview-request)

Comment 9

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ef5b98d6c07d
Remove unused PanelUI-popup code. r=mconley

Comment 10

2 years ago
Errr, this is a dupe of bug 1388029. Is there anything left to do in that bug, or should that bug be closed as a dupe of this one, seeing as this has landed now?

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ef5b98d6c07d
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
(In reply to :Gijs (no reviews; PTO recovery mode) from comment #10)
> Errr, this is a dupe of bug 1388029. Is there anything left to do in that
> bug, or should that bug be closed as a dupe of this one, seeing as this has
> landed now?

Looking at searchfox and DXR, there are still mentions of AREA_PANEL that can be removed.
Flags: needinfo?(jaws)
You need to log in before you can comment on or make changes to this bug.