Closed Bug 1410704 Opened 2 years ago Closed 2 years ago

Crash in mozalloc_abort | abort | audioipc_server::Server::poll

Categories

(Core :: Audio/Video: cubeb, defect, P3, critical)

58 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1410107
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-68ed8e3c-e871-4b59-aee4-f372e0171021.
=============================================================
Crashing Thread (16)
Frame 	Module 	Signature 	Source
0 	firefox 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:33
1 	firefox 	abort 	memory/mozalloc/mozalloc_abort.cpp:80
2 	libxul.so 	std::panicking::rust_panic 	src/libpanic_abort/lib.rs:59
3 	libxul.so 	std::panicking::rust_panic_with_hook 	src/libstd/panicking.rs:627
4 	libxul.so 	std::panicking::begin_panic<&str> 	src/libstd/panicking.rs:572
5 	libxul.so 	audioipc_server::Server::poll 	media/audioipc/server/src/lib.rs:607
6 	libxul.so 	std::sys_common::backtrace::__rust_begin_short_backtrace<closure, ()> 	media/audioipc/server/src/lib.rs:789
7 	libxul.so 	alloc::boxed::{{impl}}::call_box<(), closure> 	src/libstd/thread/mod.rs:394
8 	libxul.so 	std::sys::imp::thread::{{impl}}::new::thread_start 	src/liballoc/boxed.rs:692
Ø 9 	libpthread-2.26.so 	libpthread-2.26.so@0x7557 	
Ø 10 	libc-2.26.so 	libc-2.26.so@0xf845e 	

these crashes on linux started with firefox 58.0a1 build 20171019100107. those crashes come with MOZ_CRASH Reason "failed to insert connection" that got added in bug 1391523.
See Also: → 1410107
In that crash report, I see |e10sMultiProcesses":999|, so duping to bug 1410107.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1410107
You need to log in before you can comment on or make changes to this bug.