Closed Bug 1410107 Opened 2 years ago Closed 2 years ago

[@ mozalloc_abort | abort | audioipc_server::Server::poll ]

Categories

(Core :: Audio/Video: cubeb, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: gerard-majax, Assigned: kamidphish)

References

Details

Attachments

(3 files)

Attached file stdout
I'm hitting that, leading to huge crash of the whole nightly. Linux amd64 ubuntu 17.04, uptodate nightly.

about:crashes shows crashdump sent, matching: https://crash-stats.mozilla.com/signature/?product=Firefox&signature=mozalloc_abort%20%7C%20abort%20%7C%20audioipc_server%3A%3AServer%3A%3Apoll

STR:
 1. try to open a local file/directory

Expected:
 Displays file or directory

Actual:
 Crash
Flags: needinfo?(kinetik)
I tried reproducing using mozregression, but I could not. However, trying to load about:support also triggers the problem.
Still reproducing after disabling all extensions.
Toggling the pref media.cubeb.sandbox between true and false actually controls reproductibility: when disabling sandboxing, no more repro.
Sorry about this.  I'm not immediately sure why this is happening.  We're hitting a limit in the number of remoted cubeb contexts we handle.  Right now that's set at 16, but it's an arbitrary number we can increase, and we can also make this code not panic.  But first I'd like to understand what's causing you to hit the limit.

Do you have an unusually high number of content processes?  I think we default to 4, if I'm looking at the correct pref (dom.ipc.processCount).  How long is the browser session before you hit this crash, and how much media-related activity had you performed during that time?
Flags: needinfo?(kinetik)
I have informations that will help :).
I do have set more than 4 content process, my dom.ipc.processCount is 16 indeed. I can hit the crash as soon as I try to load a local file, or about:support, with my full session (lots of tabs, one of them including a youtube, but no playback started). So I guess the amount of processes and the current limit in cubeb context would explain that?
Flags: needinfo?(kinetik)
Rank: 10
Priority: -- → P2
See Also: → 1410537
See Also: → 1410704
Duplicate of this bug: 1410704
Assignee: nobody → dglastonbury
Dan has a fix for this in https://github.com/djg/audioipc-2/pull/15
Flags: needinfo?(kinetik)
Duplicate of this bug: 1410537
Comment on attachment 8921674 [details]
Bug 1410107 - Grow audioipc server slabs as required.

https://reviewboard.mozilla.org/r/192680/#review197862
Attachment #8921674 - Flags: review?(kinetik) → review+
Duplicate of this bug: 1410869
Pushed by dglastonbury@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aaa39a530998
Grow audioipc server slabs as required. r=kinetik
https://hg.mozilla.org/mozilla-central/rev/aaa39a530998
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Duplicate of this bug: 1411993
You need to log in before you can comment on or make changes to this bug.