Closed Bug 1410893 Opened 2 years ago Closed 2 years ago

Update webrender to 4b8493d6bdc64d2d83202ac15b06b0d4b14c6e76

Categories

(Core :: Graphics: WebRender, defect, P1)

58 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(5 files)

+++ This bug was initially created as a clone of Bug #1409736 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ a182bf7483c5ba10934dd7f9470dbc812186a1d9

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f7c9e3442807cdac0e36e0bee50d9ac29c9004f4
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9b333868d4fc464ae68b403cafcadeeca6bb7da0

Green

WR @ 205cd083421dc7ed026fbcd63e82fff77420112d

https://treeherder.mozilla.org/#/jobs?repo=try&revision=7ca77016d60c81d663529249f59dfb0aebce994e
https://treeherder.mozilla.org/#/jobs?repo=try&revision=517a691609b3fd202c1132b9be46067a61923e16

Green except for a slight increase in fuzziness for css-break/box-decoration-break-with-inset-box-shadow-1.html in R4. Regression range is

*   205cd083 Auto merge of #1910 - mstange:multiply-clip, r=glennw
|\
| * c42466c0 Always multiply alpha with the clip's alpha.
* 38f1d656 Auto merge of #1911 - mstange:bright-text-macos, r=glennw
* 8f3d9d7b Draw white on black if the font is bright, because bright text uses a different amount of font dilation.

So it's probably from servo/webrender#1910. (Related to this reftest: bug 1411074)
WR @ 3b1cf1e6ae80a3e7181a162149650c5bc55faf67

https://treeherder.mozilla.org/#/jobs?repo=try&revision=6f66ae872c144fef49dc8559a4847b7e97eeda95
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6a21bc2a965f49106e552b06a98501a861e81f22

Slight increase in fuzziness for transform-3d/backface-visibility-2.html in R8.

Regression range:

*   3b1cf1e6 Auto merge of #1915 - mstange:fix-intel-clipping, r=glennw
|\
| * 854f8738 Use a different workaround that fixes both #1809 and #1738.
* bf1869de Auto merge of #1914 - mstange:premultiplied-rectangle, r=glennw
* 3da0b935 Use premultiplied blending for rectangle primitives.

Probably from servo/webrender#1918.
Depends on: 1408481
Blocks: 1408481
No longer depends on: 1408481
WR @ 1cb8e7f016ef3c4dcd579e8c1b3350abcf39d331

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8fd277bbdd0b03418f36f368a10d73d8a6f9a47b
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad24fac98d88b379deee1e9696b790ba745f4c02

Green with a side of decreased fuzziness in css-break/box-decoration-break-with-inset-box-shadow-1.html in R4. Regression range is

* 1cb8e7f0 Auto merge of #1918 - glennw:bs-spread, r=kvark
* 782ca07d Fix inset box shadows with spread radius > border radius.

I tweaked the fuzz numbers to compensate.


WR @ f0ae29eadc6c9c3260639af1e625fd075fcd0af3

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5053406d9bf46036d48b6db8780dd2358829c53f
https://treeherder.mozilla.org/#/jobs?repo=try&revision=02b2184a190045c9a07f500e91088a760677ad66

Green
Right now builds are broken as of servo/webrender#1923. Gankro provided a gecko patch in that issue but it requires bug 1401653 to be in first, and that just got backed out of autoland. So we're on hold until that gets sorted out.
WR @ 42263344b9820e7252a617a8d2a54f9e0e9565f3

https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e5fddfb10f1e8b09e096453fb1a773110e96024
https://treeherder.mozilla.org/#/jobs?repo=try&revision=24e80c5ba5a718591ea072a217d96fa0a3bc9935

Green

WR @ 038a223b5ec14086ff2cd77832e90c15d0453cd2

https://treeherder.mozilla.org/#/jobs?repo=try&revision=acb1480b5c0bce81311095a5a00ed33c1330d42c
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e815619509020b16ccbaea40a4f9e2892e8a210e

Much orange, looks like a crash in texture cache locking code. Regression range:

*   038a223b Auto merge of #1945 - lsalzman:color-bitmap-blend, r=glennw
|\
| * 9fb8ab8f remember GlyphFormat in glyph cache and pass to text run shader
*   c47d106c Auto merge of #1920 - mephisto41:improve-blur, r=glennw
|\
| * e1f0c80e Tweak blur filter.
* 844779d1 Auto merge of #1942 - kvark:flatten, r=glennw
* 72692761 Move flattening logic into FlattenContext
* 18b12e50 Synchonized font instance map

Nothing here looks super relevant so it might be a regression on the gecko side. I'll do some more try pushes to narrow it down.
I did the cross-build try pushes:

new WR with older autoland cset [1] - busted
old WR with newer m-c cset [2] - green

So this is definitely a breakage from a change in upstream WR. Bisecting the range from the last comment, but #1942 looks like the most likely culprit.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=346514879173d2bebc49ba846b9819c2dfa93b86
[2] https://treeherder.mozilla.org/#/jobs?repo=try&revision=705b6c62699a7ded031e0d2cc1e8b66c2b525d1d
Bisection push with WR @ 844779d1 confirms bustage: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f4773a25f60ecf0e6cc22a615998a621f0e00586

So #1942 is definitely where it's coming from. :kvark is looking into it.
The fix is in servo/webrender#1948. Try push with that applied is at https://treeherder.mozilla.org/#/jobs?repo=try&revision=08b5790d2d7842580be509e4a516611a1f3bdccf - there are a bunch of reftest changes from #1920. I'll update the reftest results for those.
^ Linux is green (The R7 failure is because I fat-fingered one of the reftest adjustments). But Windows is red, getting another shader compilation failure:

thread '<unnamed>' panicked at 'called `Result::unwrap()` on an `Err` value: Link("debug_font", "Precisions for uniform \'uMode\' differ between vertex and fragment shaders\n")', src\libcore\result.rs:906:4

Looking back the try pushes the regression range for this is:

*   038a223b Auto merge of #1945 - lsalzman:color-bitmap-blend, r=glennw
|\
| * 9fb8ab8f remember GlyphFormat in glyph cache and pass to text run shader
*   c47d106c Auto merge of #1920 - mephisto41:improve-blur, r=glennw
|\
| * e1f0c80e Tweak blur filter.
* 844779d1 Auto merge of #1942 - kvark:flatten, r=glennw
* 72692761 Move flattening logic into FlattenContext
* 18b12e50 Synchonized font instance map

Based on the diffs I think this is coming from 9fb8ab8f, aka servo/webrender#1945.
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 4b8493d6bdc64d2d83202ac15b06b0d4b14c6e76
Version: unspecified → 58 Branch
Comment on attachment 8922785 [details]
Bug 1410893 - Update webrender to commit 4b8493d6bdc64d2d83202ac15b06b0d4b14c6e76.

https://reviewboard.mozilla.org/r/193936/#review199038
Attachment #8922785 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8922786 [details]
Bug 1410893 - Update Cargo lockfiles and re-generate FFI header.

https://reviewboard.mozilla.org/r/193938/#review199040
Attachment #8922786 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8922787 [details]
Bug 1410893 - Update reftest results for changes in WR PR 1910.

https://reviewboard.mozilla.org/r/193940/#review199044
Attachment #8922787 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8922788 [details]
Bug 1410893 - Update bindings for API changes in WR PR 1923.

https://reviewboard.mozilla.org/r/193942/#review199046
Attachment #8922788 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8922789 [details]
Bug 1410893 - Update reftest results for WR PR 1920.

https://reviewboard.mozilla.org/r/193944/#review199050
Attachment #8922789 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55f33f1364a7
Update webrender to commit 4b8493d6bdc64d2d83202ac15b06b0d4b14c6e76. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/0eb02890fae4
Update Cargo lockfiles and re-generate FFI header. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/a94e6f39f062
Update reftest results for changes in WR PR 1910. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/1fd7e1d19df0
Update bindings for API changes in WR PR 1923. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/a9eb465811d0
Update reftest results for WR PR 1920. r=jrmuizel
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
You need to log in before you can comment on or make changes to this bug.