Closed Bug 1411195 Opened 6 years ago Closed 3 months ago

Long paint times on certain pages with large blurs.

Categories

(Core :: Graphics, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: dietrich, Unassigned)

References

Details

(Keywords: perf, regressionwindow-wanted, Whiteboard: [gfx-noted])

58.0a1 (2017-10-23) (64-bit) Mac OS X

I see a very visible delay in the tab bar itself when using keyboard shortcuts to traverse tabs, and I pass over a tab with this URL in it:

https://developer.android.com/guide/topics/appwidgets/index.html

Here's a video: https://gfycat.com/gifs/detail/YellowImpishFlee

You can see that as I repeatedly traverse the tabs back and forth, that particular tab never gets the focus color change, except once when I briefly stopped.

I changed the location of the tab in the tab bar and continue - same behavior.
Is this a regression?
Flags: needinfo?(dietrich)
Are you able to get a profile via the Gecko Profiler Add-on when doing this?

https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem in case it's been a while.
Priority: -- → P3
Keywords: perf
https://perfht.ml/2ll3iSs

~350ms rasterizing each time i go past the tab.
Flags: needinfo?(dietrich)
Oof, yep, that's a big paint.

I'll see if I can get jrmuizel to look at this with me on Friday during Joy of Profiling.
Component: Tabbed Browser → Graphics
Product: Firefox → Core
We looked at this today during The Joy of Profiling: https://air.mozilla.org/the-joy-of-profiling-episode-14/

Apparently, there's a pretty expensive blurring effect that's occurring somewhere on the page (we didn't succeed in finding it) that we're doing on the main thread.

We do this kind of blurring effect on the main thread on macOS and Linux. This bug does not affect Windows.

WebRender allows us to do the effect entirely on the GPU, and (in our testing) appears to address the performance problem. So that's probably the solution to this - WebRender.
Summary: visible lag when switching between tabs for this URL → Long paint times on certain pages with large blurs.
Whiteboard: [gfx-noted]
Severity: normal → S3

Unable to reproduce in current versions.

So that's probably the solution to this - WebRender.

💯

Status: NEW → RESOLVED
Closed: 3 months ago
Depends on: fixed-by-webrender
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.