Closed Bug 1411503 Opened 4 years ago Closed 3 years ago

New browser/dialog window is white for 5-10 sec (no UI element and contents)

Categories

(Core :: Graphics: WebRender, defect, P2)

x86_64
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- disabled
firefox60 --- disabled
firefox61 --- disabled
firefox62 --- verified

People

(Reporter: alice0775, Assigned: sotaro)

References

Details

(Keywords: perf, Whiteboard: [wr-reserve][gfx-noted])

Attachments

(2 files, 2 obsolete files)

Attached file about_support.txt (obsolete) —
Build Identifier:
Build ID 	20171024220325
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Reproducible: always

Steps To Reproduce:
1. Enabled webrender
user_pref("gfx.webrender.enabled", true);
user_pref("gfx.webrender.layers-free", true);
user_pref("gfx.webrender.blob-images", true);
user_pref("gfx.webrendest.enabled", true);

2. Launch nightly, and open any dialog

Actual Results:
window is black temporarily. After about 3-5 dec, the window/dialog is rendering properly.

Expected Results:
Not delay.
Attached image screenshot (obsolete) —
Whiteboard: [wr-mvp] [triage]
Priority: -- → P3
Whiteboard: [wr-mvp] [triage] → [wr-mvp] [triage][wr-reserve-candidate]
Whiteboard: [wr-mvp] [triage][wr-reserve-candidate] → [wr-reserve]
Whiteboard: [wr-reserve] → [wr-reserve][gfx-noted]
Thank you!
Confirmed in Nightly 58 x64 20171102100041 de_DE @ Windows 10 1703 (Radeon RX480).
fresh profile: gfx.webrender.enabled

I had the same observation an hour ago:
(Jan Andre Ikenmeyer [:darkspirit] from bug 1413961 comment 4)
> In general, WebRender(?) starts slow on Windows: A freshly started Nightly has a completely black window for about 2 seconds. 
> The same when using Awesomebar for the first time: A black box (the Awesomebar) pops down and just after ca. 2 seconds it has its regular content.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Black for about 2 seconds with gfx.webrender.force-angle;true (default),
white for about 0.2 seconds with gfx.webrender.force-angle;false:
* Nightly start
* First use of Awesomebar
* First opening of Help > About
* about:profiles > Create new profile
today, white window for a long time instead black...
Summary: New browser/dialog window is black temporarily → New browser/dialog window is white temporarily
Summary: New browser/dialog window is white temporarily → New browser/dialog window is white for 5-10 sec (no UI element and contents)
Attached file about:support
Attachment #8921778 - Attachment is obsolete: true
Attached video screenshot
Attachment #8921779 - Attachment is obsolete: true
See Also: → 1435125
gecko profiler log from start up(set MOZ_PROFILER_STARTUP=1)

WebRender on:  https://perfht.ml/2E6gKyp
WebRender off: https://perfht.ml/2E5Q3Kp
Sotaro, this didn't get any slower recently, right?  We still have the first one take a while, then cache enough stuff to make the subsequent windows being created faster?
Assignee: nobody → sotaro.ikeda.g
Flags: needinfo?(sotaro.ikeda.g)
It didn't get slower recently. First window drawing is already slow. But it seemed gradually getting slower by growing glsl shader code size though. 2nd window should be relatively fast compared to 1st window

I got start up profile with the following command from it. With it, majority of time was spent for compiling glsl by ANGLE on Renderer thread.

 >  MOZ_PROFILER_STARTUP=1 MOZ_PROFILER_STARTUP_FILTERS=GeckoMain,Compositor,Renderer "/c/Program Files/Nightly/firefox.exe"

https://perfht.ml/2FRTSDf
Flags: needinfo?(sotaro.ikeda.g)
Depends on: 1418202
See Also: → 1453244
See Also: → 1423671
See Also: → 1465595
new windows seem to open in ~1 second for me now that bug 1418202 is resolved, can you confirm the issue is resolved for you?
Flags: needinfo?(alice0775)
It's a little slower than wrbrender off in the new profile.
But, I do not care anymore.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(alice0775)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.