Make the accessibility visual indicator off by default in 57

VERIFIED FIXED in Firefox 57

Status

()

defect
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: davidb, Assigned: yzen)

Tracking

unspecified
mozilla58
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox57blocking verified, firefox58 verified)

Details

Attachments

(1 attachment)

No description provided.
I'd like to track this as a 57 blocker. The sooner we have a patch ready for uplift the better. RC week begins Nov6th.
Posted patch 1411591 patchSplinter Review
Attachment #8922808 - Flags: review?(dbolter)
Comment on attachment 8922808 [details] [diff] [review]
1411591 patch

Review of attachment 8922808 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8922808 - Flags: review?(dbolter) → review+
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c34e87883dcd
making accessibility indicator off by default. r=davidb
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/c34e87883dcd
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Comment on attachment 8922808 [details] [diff] [review]
1411591 patch

Approval Request Comment
[Feature/Bug causing the regression]: Not a regression. Decision has been made to pref off the accessibility indicator by default in Firefox 57 and do a Shield Study to better understand the effect of the indicator on Firefox users (whether it is positive or confusing).
[User impact if declined]: From telemetry it looks like 7% of users will see the indicator. We would not want to confuse them so we are leaning towards a Shield study first.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Just a pref change to not show accessibility indicator. It is already covered by tests.
[String changes made/needed]: None
Attachment #8922808 - Flags: approval-mozilla-beta?
Comment on attachment 8922808 [details] [diff] [review]
1411591 patch

Must fix, Beta57+
Attachment #8922808 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Blocks: 1412603
Verified fixed in 57.b13 & Nightly 58.0a1 (id: 20171031235118).
The Accessibility icon does not appear anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.