Closed Bug 1411822 Opened 2 years ago Closed 2 years ago

Intermittent /webrtc/RTCDTMFSender-ontonechange-long.https.html | insertDTMF with duration greater than 6000 should be clamped to 6000 - assert_approx_equals: Expect tonechange event for "" to be fired approximately after 6070 seconds expected 6070 +/- 5

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: drno)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

Attachments

(1 file)

Duplicate of this bug: 1411975
In the last 7 days, there have been 56 failures.
Most of the failures occur on Linux, but a few of them are on OS X 10.10. All of them on debug.

Here is a recent example of the log: https://treeherder.mozilla.org/logviewer.html#?repo=autoland&job_id=141254506&lineNumber=5530

And the log part where the test failed:
[task 2017-11-01T06:14:25.748Z] 06:14:25     INFO - PID 15773 | --DOMWINDOW == 11 (0xd15dcc00) [pid = 15821] [serial = 32] [outer = (nil)] [url = about:blank]
32237
[task 2017-11-01T06:14:25.748Z] 06:14:25     INFO - PID 15773 | --DOMWINDOW == 10 (0xd15d6c00) [pid = 15821] [serial = 26] [outer = (nil)] [url = about:blank]
32238
[task 2017-11-01T06:14:25.748Z] 06:14:25     INFO - PID 15773 | --DOMWINDOW == 9 (0xd15bd800) [pid = 15821] [serial = 25] [outer = (nil)] [url = about:blank]
32239
[task 2017-11-01T06:14:25.749Z] 06:14:25     INFO - PID 15773 | --DOMWINDOW == 8 (0xe18d9c00) [pid = 15821] [serial = 5] [outer = (nil)] [url = http://web-platform.test:8000/testharness_runner.html]
32240
[task 2017-11-01T06:14:26.012Z] 06:14:26     INFO - 
32241
[task 2017-11-01T06:14:26.012Z] 06:14:26     INFO - TEST-UNEXPECTED-FAIL | /webrtc/RTCDTMFSender-ontonechange-long.https.html | insertDTMF with duration greater than 6000 should be clamped to 6000 - assert_approx_equals: Expect tonechange event for "" to be fired approximately after 6070 seconds expected 6070 +/- 50 but got 6182
32242
[task 2017-11-01T06:14:26.012Z] 06:14:26     INFO - test_tone_change_events/</</onToneChange<@https://web-platform.test:8443/webrtc/RTCDTMFSender-helper.js:79:9
32243
[task 2017-11-01T06:14:26.013Z] 06:14:26     INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1489:20
32244
[task 2017-11-01T06:14:26.013Z] 06:14:26     INFO - Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1513:20
32245
[task 2017-11-01T06:14:26.014Z] 06:14:26     INFO - TEST-OK | /webrtc/RTCDTMFSender-ontonechange-long.https.html | took 6839ms

:jgraham, can you please help prioritize this bug?
Flags: needinfo?(james)
Putting this in the WebRTC component. I suspect the issue is that the test is timing sensitive and debug builds can be slow. Hopefully someone working on WebRTC can fix the test to be more tolerant.
Component: web-platform-tests → WebRTC
Flags: needinfo?(james)
Product: Testing → Core
Version: Version 3 → unspecified
:jgraham, thanks!
Whiteboard: [stockwell needswork]
:drno, is this something you could look at?
Flags: needinfo?(drno)
Same problem as in bug 1398308: the expectations from the upstream tests are too tight.
Flags: needinfo?(drno)
See Also: → 1398308
For this kind of change, unless we expect it to be controversial, it makes sense to land it directly in m-c so we get the benefit immediately and then later let the two-way sync handle upstreaming it.
(by m-c I obviously mean inbound or autoland)
(In reply to James Graham [:jgraham] from comment #10)
> For this kind of change, unless we expect it to be controversial, it makes
> sense to land it directly in m-c so we get the benefit immediately and then
> later let the two-way sync handle upstreaming it.

I did not know that there is a two-way sync.
I also don't know if this is controversial. I assume not. So here we go.
Comment on attachment 8925704 [details]
Bug 1411822: increase DTMF timeout range value.

https://reviewboard.mozilla.org/r/196838/#review202072

Looks good to me.
Attachment #8925704 - Flags: review?(mfroman) → review+
Assignee: nobody → drno
Pushed by drno@ohlmeier.org:
https://hg.mozilla.org/integration/autoland/rev/2167381ba501
increase DTMF timeout range value. r=mjf
https://hg.mozilla.org/mozilla-central/rev/2167381ba501
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.