Closed Bug 1412565 Opened 2 years ago Closed 2 years ago

Crash in webrender_bindings::bindings::wr_dec_ref_arc

Categories

(Core :: Graphics: WebRender, defect, P1, critical)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: yoasif, Assigned: jrmuizel)

References

Details

(Keywords: crash, nightly-community, regression, Whiteboard: [wr-mvp])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-cd16416f-339f-40ab-8acf-92c930171028.
=============================================================

This started in the latest Nightly. Hard to track down the issue via mozregression since it can take a while to happen. 

31:10.48 INFO: Got as far as we can go bisecting nightlies...
31:10.48 INFO: Last good revision: d58424c244c38f88357a26fb61c333d3c6e552d7 (2017-10-27)
31:10.48 INFO: First bad revision: c16bc8097c102cdd2b70d8e7db3656222455a6ed (2017-10-28)
31:10.48 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d58424c244c38f88357a26fb61c333d3c6e552d7&tochange=c16bc8097c102cdd2b70d8e7db3656222455a6ed
Webrender bindings are broken (bug 1412280 comment 2, bug 1412545 comment 2). disabling blob-images seems to fix it.
Status: NEW → RESOLVED
Closed: 2 years ago
OS: All → Linux
Hardware: Unspecified → x86_64
Resolution: --- → DUPLICATE
Version: 58 Branch → Trunk
Duplicate of bug: 1412545
I'm pretty sure I put this in with bug 1380014
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: 1380014
Whiteboard: [wr-mvp] [triage]
Assignee: nobody → jmuizelaar
Attachment #8923655 - Flags: review?(lsalzman)
Attachment #8923655 - Flags: review?(lsalzman) → review+
Status: REOPENED → ASSIGNED
Priority: -- → P1
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1d01a3b06748
Release the vec before deleting the item. r=lsalzman
https://hg.mozilla.org/mozilla-central/rev/1d01a3b06748
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Nightly 58 x64 20171030103605 de_DE @ Debian Testing (KDE, Radeon RX480)
main profile: gpu process, layers force accel, webrender, blob-images, omtp, stylo-chrome

Still the old Nightly because of bug 1413204. Therefore I do not have the fix from comment 3.

Observation: These signatures come as pair. May we add the other one to this bug?

bp-4cba6813-374e-42e2-9e9d-099b40171030 31.10.17 00:19
[@ mozilla::ipc::MessageChannel::Send | mozilla::layers::PAPZCTreeManagerChild::SendUpdateZoomConstraints ]
bp-8c0c5744-c5e1-4cda-add3-fa4d70171030 31.10.17 00:19
this bug: [@ webrender_bindings::bindings::wr_dec_ref_arc ]

bp-eb82575e-0fa2-4a35-a5eb-9deab0171030 30.10.17 16:25
[@ mozilla::ipc::MessageChannel::Send | mozilla::layers::PAPZCTreeManagerChild::SendUpdateZoomConstraints ]
bp-4104bdad-8e3e-4ee5-952d-3eac90171030 30.10.17 16:25
this bug: [@ webrender_bindings::bindings::wr_dec_ref_arc ]
You need to log in before you can comment on or make changes to this bug.