Closed Bug 1413203 Opened 2 years ago Closed Last month

The css for about:networking is not loading in Android

Categories

(Firefox for Android :: General, defect, P3)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr68 --- wontfix
firefox70 --- wontfix
firefox71 --- verified

People

(Reporter: valentin, Assigned: valentin)

References

(Depends on 1 open bug)

Details

(Whiteboard: [geckoview:p3][necko-triaged] )

Attachments

(2 files)

Go to about:networking
You will notice that there is no styling for the page.
It seems that the path chrome://mozapps/skin/aboutNetworking.css is not accessible on Android.
Not sure exactly what the approach here should be, or when this got broken.
Please help prioritize this.
Flags: needinfo?(wehuang)
Though the css setting is not used here, the page I saw seems readible and not many item to toggle (screenshot attached)? Valentin, would you help me learn more about the expected look from a user's perspective? Thanks.
Flags: needinfo?(wehuang) → needinfo?(valentin.gosu)
Attached image about networking.jpg
(In reply to Wesly Huang (Fennec Frontend/Firefox EPM) from comment #2)
> Though the css setting is not used here, the page I saw seems readible and
> not many item to toggle (screenshot attached)? Valentin, would you help me
> learn more about the expected look from a user's perspective? Thanks.

The page should look the same or similar to what it looks on desktop. (about:networking)
At least the hiding and unhiding sections should work.
Flags: needinfo?(valentin.gosu)
Thanks Valentin! Then all sections except "HTTP" are inaccessible comparing with Desktop, which should be fixed. rise to P2.
Priority: -- → P2
[triage] Developer feature, non-critical.
Priority: P2 → P3
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P3 → P5
Depends on: 1354779
Priority: P5 → P3
Whiteboard: [geckoview][necko-triaged]
Duplicate of this bug: 1509816
Whiteboard: [geckoview][necko-triaged] → [geckoview:p3][necko-triaged]
  • Make about:networking work on mobile
  • I used the aboutMemory.css file as a guide for doing this
  • The mobile CSS does not include the common.css, since that doesn't seem to work. But at least now the interfaces is functional. We should make it look nice in a follow-up.
Assignee: nobody → valentin.gosu
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1e81cd6ced84
The css for about:networking is not loading in Android r=Gijs

Fixed it. We were still referencing the old aboutNetworking.css path in that test.

Flags: needinfo?(valentin.gosu)
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d7ca36975685
The css for about:networking is not loading in Android r=Gijs
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Setting status flags firefox70=wontfix and firefox-esr68=wontfix because we don't need to uplift this fix to GeckoView 70 Beta or Fennec ESR 68.

Hi, verified as fixed with the link from Comment 14 on build named "geckoview_example.apk" and Fenix/Firefox Preview Nightly 101023 (Build #12960607)-GeckView 71.0a1-20191021095628 with 2 devices: Samsung Galaxy S8+ (Android 8.0.0) and Sony Xperia Z5 (Android 7.0.0).
Functionally, now when I tap on each available section from about:networking each of them display the information on both mentioned builds.

Note:

  • From my point of view, the information seems to be cramped up - meaning that there is no limit between the sections and the information for them - I will put a screenshot here to see what i mean.
OS: Unspecified → Android
Hardware: Unspecified → ARM

(In reply to Diana Rus from comment #16)

  • From my point of view, the information seems to be cramped up - meaning that there is no limit between the sections and the information for them - I will put a screenshot here to see what i mean.

Thanks Diana. You are absolutely correct. I filed bug 1590671 to make it look nicer.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.