Closed Bug 1413283 Opened 2 years ago Closed Last year

Mark ctor-constantsource.html as passing, since bug 1456266 landed

Categories

(Core :: Web Audio, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: toy.raymond, Assigned: leo.paquet)

Details

(Keywords: dev-doc-complete, Whiteboard: [need info padenot 2017-11-01])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.18 Safari/537.36

Steps to reproduce:

n = new ConstantSourceNode(context)

Examine n.channelCount,


Actual results:

channelCount is 1.


Expected results:

channelCount should be 2.

(Not that this really matters since the channelCount applies to inputs and a ConstantSourceNode has none.)
Component: Untriaged → Web Audio
Product: Firefox → Core
Paul, can you please asses if this is a real problem and what's the priority?
Flags: needinfo?(padenot)
Whiteboard: [need info padenot 2017-11-01]
I'm going to mark this as P3 becase there is no clear/immediate user impact.
Priority: -- → P3
Clearing NI.

Léo, do you want to take this one? Or maybe someone else?
Flags: needinfo?(padenot) → needinfo?(leo.paquet)
(In reply to Paul Adenot (:padenot) from comment #3)
> Clearing NI.
> 
> Léo, do you want to take this one? Or maybe someone else?

Yes, I'll take it.
Flags: needinfo?(leo.paquet)
Assignee: nobody → leo.paquet
Status: UNCONFIRMED → ASSIGNED
Rank: 25
Ever confirmed: true
This doc is still saying "Channel count equals 1" : https://developer.mozilla.org/en-US/docs/Web/API/ConstantSourceNode
The right place to look is https://webaudio.github.io/web-audio-api/#ConstantSourceNode, but I see that there's a spec bug that channelCount isn't mentioned here.  However, https://webaudio.github.io/web-audio-api/#dom-audionode-channelcount says the default is 2 unless otherwise stated.
(In reply to Léo Paquet from comment #6)
> This doc is still saying "Channel count equals 1" :
> https://developer.mozilla.org/en-US/docs/Web/API/ConstantSourceNode

This is a manual, and is not authoritative. That said, you can change it, it's a wiki !
Comment on attachment 8926778 [details]
Bug 1413283 - ConstantSourceNode properties incorrect.

https://reviewboard.mozilla.org/r/198022/#review204532

Thanks! Sorry for the delay in reviewing this.
Attachment #8926778 - Flags: review?(padenot) → review+
NI so I land this and update expectations.
Flags: needinfo?(padenot)
Hrm this also has landed in bug 1456266, I'm just going to update expectations.
Status: ASSIGNED → NEW
Flags: needinfo?(padenot)
Summary: ConstantSourceNode properties incorrect → Mark ctor-constantsource.html as passing, since bug 1456266 landed
Comment on attachment 8993418 [details]
Bug 1413283 - Remove another WPT expectation file.

https://reviewboard.mozilla.org/r/258172/#review265290
Attachment #8993418 - Flags: review?(karlt) → review+
Pushed by paul@paul.cx:
https://hg.mozilla.org/integration/autoland/rev/724fef1b5487
Remove another WPT expectation file. r=karlt
https://hg.mozilla.org/mozilla-central/rev/724fef1b5487
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Fixed the doc to say that ConstantSourceNode has 2 channels. Updated Firefox 63 for developers.
You need to log in before you can comment on or make changes to this bug.