Closed Bug 1413575 Opened 3 years ago Closed 2 years ago

Merge mozbase docs with in-tree documentation

Categories

(Testing :: Mozbase, enhancement)

enhancement
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: ahal, Assigned: tomprince)

References

Details

Attachments

(2 files)

We currently build and publish the mozbase documentation on readthedocs:
http://mozbase.readthedocs.io/en/latest/

This should just live with the rest of the in-tree documentation at:
https://firefox-source-docs.mozilla.org/

There's probably no need to keep the readthedocs version up and running, we can publish a link to the new documentation in its place.
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Comment on attachment 8930171 [details]
Bug 1413575: Add mozbase docs to sphinx tree.

https://reviewboard.mozilla.org/r/201326/#review206954
Attachment #8930171 - Flags: review?(ahalberstadt) → review+
Comment on attachment 8930172 [details]
Bug 1413575: Adjust in-tree references to mozbase documentation to point in-tree.

https://reviewboard.mozilla.org/r/201328/#review206956

Thanks for jumping on this! Let me know if you need me to autoland.
Attachment #8930172 - Flags: review?(ahalberstadt) → review+
No, I've got autoland privileges. But this depends on Bug 1402154 (which apparently I've forgotten to add to the metadata here).
Depends on: 1402154
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/49346c4e1046
Add mozbase docs to sphinx tree. r=ahal
https://hg.mozilla.org/integration/autoland/rev/00f6b8f2e196
Adjust in-tree references to mozbase documentation to point in-tree. r=ahal
https://hg.mozilla.org/mozilla-central/rev/49346c4e1046
https://hg.mozilla.org/mozilla-central/rev/00f6b8f2e196
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1398121
Duplicate of this bug: 974158
Duplicate of this bug: 1535550
You need to log in before you can comment on or make changes to this bug.