Closed Bug 141406 Opened 19 years ago Closed 15 years ago

Missing VALARM properties action/description and used trigger value

Categories

(Calendar :: Internal Components, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 298358

People

(Reporter: ajbu, Assigned: mostafah)

References

()

Details

According to the iCalendar rfc, the VALARM object should have an ACTION 
property.
When using ACTION:DISPLAY there should also be a DESCRIPTION property for the 
valarm object.

Also note that Mozilla Calendar uses a trigger defined with: 
TRIGGER;VALUE=DURATION:-PT15M
Although I didn't have any problems when importing that, I couldn't find this 
duration parameter in the rfc, found definition of DURATION only as a property 
of VALARM. (as in the sample from the rfc below)

-=-=-=-=-
   The "VALARM" calendar component MUST include the "ACTION" and
   "TRIGGER" properties. The "ACTION" property further constrains the
   "VALARM" calendar component in the following ways

   When the action is "DISPLAY", the alarm MUST also include a
   "DESCRIPTION" property, which contains the text to be displayed when
   the alarm is triggered.

   When the action is "AUDIO", the alarm can also include one and only
   one "ATTACH" property, which MUST point to a sound resource, which is
   rendered when the alarm is triggered.
-=-=-
    The following example is for a "VALARM" calendar component that
   specifies a display alarm that will trigger 30 minutes before the
   scheduled start of the event or the due date/time of the to-do it is
   associated with and will repeat 2 more times at 15 minute intervals:

     BEGIN:VALARM
     TRIGGER:-PT30M
     REPEAT:2
     DURATION:PT15M
     ACTION:DISPLAY
Taking bug. This is backend stuff
Assignee: mikep → mostafah
Component: Calendar General → libxpical
Confirmed bug. ACTION is definitely needed.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: 135558
To be complete, I didn't mention the EMAIL en PROCEDURE actions. EMAIL might 
be usefull when sending events to a calendar-server:

   When the action is "EMAIL", the alarm MUST include a "DESCRIPTION"
   property, which contains the text to be used as the message body, a
   "SUMMARY" property, which contains the text to be used as the message
   subject, and one or more "ATTENDEE" properties, which contain the
   email address of attendees to receive the message. It can also
   include one or more "ATTACH" properties, which are intended to be
   sent as message attachments. When the alarm is triggered, the email
   message is sent.

   When the action is "PROCEDURE", the alarm MUST include one and only
   one "ATTACH" property, which MUST point to a procedure resource,
   which is invoked when the alarm is triggered.
We should do what we can for 1.0.
Target Milestone: --- → 1.0
Default QA Contact for Calendar has changed.  If you wish to remain the QA
contact for this bug, feel free to change it back.
QA Contact: colint → brantgurganus2001
I'm handling this in bug 298358.  Marking as duplicate.

*** This bug has been marked as a duplicate of 298358 ***
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Mass move of libxpical bugs to the Internal Components, per ctalbert.
Component: libxpical → Internal Components
The bugspam monkeys have been set free and are feeding on Calendar :: Internal Components. Be afraid for your sanity!
QA Contact: gurganbl → base
Target Milestone: 1.0 → ---
You need to log in before you can comment on or make changes to this bug.