Choosing a light theme results in hard to read text in the Private Browsing Awesomebar

VERIFIED FIXED in Firefox 58

Status

()

P1
normal
VERIFIED FIXED
a year ago
8 months ago

People

(Reporter: mark.paxman99, Assigned: JanH)

Tracking

(Blocks: 1 bug)

Firefox 57
Firefox 59
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox56 unaffected, firefox57 wontfix, firefox58 verified, firefox59 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171103100331

Steps to reproduce:

Select a new theme for Fennec Nightly 2017-11-03. 
Choose a light gray colour.
I tried "Linen Light" and "Mac OSX Light"
Open a Private Browsing tab
Type in the Awesomebar
The Awesomebar text is white on a light gray background and is very hard to read

I suggest that Private Browsing should not emulate the Theme colour in the text field
(Assignee)

Comment 1

a year ago
I think this might be a side effect of bug 1389164, but given that we don't actually style the toolbar in private mode, the changed background isn't actually required there.
Blocks: 1355774, 1389164
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
status-firefox56: --- → wontfix
status-firefox57: --- → fix-optional
status-firefox58: --- → affected
Component: General → Theme and Visual Design
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
(Assignee)

Updated

a year ago
status-firefox56: wontfix → unaffected

Updated

a year ago
tracking-fennec: ? → +
Priority: -- → P1
status-firefox59: --- → affected
(Assignee)

Updated

a year ago
Assignee: nobody → jh+bugzilla
status-firefox57: fix-optional → wontfix
Comment hidden (mozreview-request)
Hi Carol.
Please help advise
Flags: needinfo?(chuang)
Created attachment 8939477 [details]
Screenshot_private-tab.png

I attached a screenshot to make sure we're talking about the same thing.
Since we don't apply LWT to the private tab, I'll suggest removing the light grey bg on the tool bar for the private tab.

Nevin, let me know if there will be any concerns removing the box bg. thank you :)
Flags: needinfo?(chuang) → needinfo?(cnevinchen)
(Assignee)

Comment 5

a year ago
(In reply to Carol Huang [:Carol] from comment #4)
> I attached a screenshot to make sure we're talking about the same thing.
> Since we don't apply LWT to the private tab, I'll suggest removing the light
> grey bg on the tool bar for the private tab.


Yup, that's the thing I mean.

Comment 6

a year ago
mozreview-review
Comment on attachment 8938664 [details]
Bug 1414309 - Tell ToolbarEditLayout's title background about private mode changes.

https://reviewboard.mozilla.org/r/209270/#review215668
Attachment #8938664 - Flags: review?(cnevinchen) → review+
LGTM. Thanks!
Flags: needinfo?(cnevinchen)

Comment 8

a year ago
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/da52ff7129ad
Tell ToolbarEditLayout's title background about private mode changes. r=nechen

Comment 9

a year ago
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/bfdc585f72b3
Tell ToolbarEditLayout's title background about private mode changes. r=nechen

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/bfdc585f72b3
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox59: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
(Assignee)

Comment 11

a year ago
Comment on attachment 8938664 [details]
Bug 1414309 - Tell ToolbarEditLayout's title background about private mode changes.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1389164
[User impact if declined]: If a theme has been installed, text entered into the URL bar during private browsing will be harder to read because of the light background
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: Tested locally.
[Needs manual test from QE? If yes, steps to reproduce]: No. 
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Small changes to disable the light background in private mode, doing the same thing that already happens when the URL bar doesn't have the input focus.
[String changes made/needed]: no
Attachment #8938664 - Flags: approval-mozilla-beta?
Comment on attachment 8938664 [details]
Bug 1414309 - Tell ToolbarEditLayout's title background about private mode changes.

A UI enhancement. Beta58+.

Hi Ioana,
could you help find someone to verify if this issue was fixed as expected on the latest Nightly build? Thanks!
Flags: needinfo?(ioana.chiorean)
Attachment #8938664 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+

Comment 14

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/46fabe0cc9dc
status-firefox58: affected → fixed

Comment 15

a year ago
Verified as fixed in Nightly 59 (2018-01-08).
Devices:
Google Pixel (Android 8.0)
Oneplus Two (Android 6.0.1)
status-firefox59: fixed → verified
Flags: needinfo?(ioana.chiorean)
Verified as fixed in build 58.0b17.
Devices: Google Pixel (Android 8.0), Huawei MediaPad M2 (Android 5.1.1), Samsung Galaxy Tab 3 (Android 7.0).
status-firefox58: fixed → verified
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.