As a security precaution, we have turned on the setting "Require API key authentication for API requests" for everyone. If this has broken something, please contact bugzilla-admin@mozilla.org
Last Comment Bug 141432 - right click on disabled form control should show the "normal" content menu
: right click on disabled form control should show the "normal" content menu
Status: NEW
:
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
: 297979 785756 (view as bug list)
Depends on: 100085
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-01 03:54 PDT by Henrik Gemal
Modified: 2014-02-15 07:15 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Henrik Gemal 2002-05-01 03:54:08 PDT
if you have a disables form control ala:
<input type="text" disable="true">
and right on it no context menu is shown. Normally a form control context menu
is shown. But in stead of showing no context menu we should just show the normal
context menu. Like when you right on anywhere on the page.

20020430
Comment 1 User image Boris Zbarsky [:bz] (still a bit busy) 2002-05-01 08:37:24 PDT
To blake; this has nothing to do with form controls.
Comment 2 User image Boris Zbarsky [:bz] (still a bit busy) 2002-05-01 08:58:31 PDT
er, to blake for real
Comment 3 User image Martijn Wargers [:mwargers] 2005-07-11 11:54:02 PDT
Isn't this a duplicate of bug 100085?
Comment 4 User image Serge Gautherie (:sgautherie) 2008-06-10 09:58:32 PDT
Filter "spam" on "guifeatures-nobody-20080610".
Comment 5 User image Adam 2010-12-22 11:53:19 PST
Is there anything being done to fix this issue?  It's been reported numerous times:
https://bugzilla.mozilla.org/show_bug.cgi?id=297979
https://bugzilla.mozilla.org/show_bug.cgi?id=257623

And seems to be related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=195361
https://bugzilla.mozilla.org/show_bug.cgi?id=253870
Comment 6 User image :Gijs 2012-02-01 02:31:47 PST
*** Bug 297979 has been marked as a duplicate of this bug. ***
Comment 7 User image Matthias Versen [:Matti] 2012-08-26 16:04:47 PDT
*** Bug 785756 has been marked as a duplicate of this bug. ***
Comment 8 User image Alexey Zinovyev 2014-02-15 07:15:57 PST
Looks like this bug was fixed recently.

Note You need to log in before you can comment on or make changes to this bug.