Cannot right-click on disabled button/input/optgroup/select/textarea form elements

RESOLVED DUPLICATE of bug 141432

Status

()

defect
RESOLVED DUPLICATE of bug 141432
14 years ago
3 months ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When you right-click on a disabled button/input/optgroup/select/textarea form
elements, the right-click is ignored and nothing happens.

Reproducible: Always

Steps to Reproduce:
1. Find a page with a disabled button/input/optgroup/select/textarea form element.
2. Right-click on it.


Actual Results:  
Right-click is ignored and nothing happens.

Expected Results:  
The regular page context menu should be shown the same way it is shown when you
right-click on an ENABLED <input type="radio"> button or an ENABLED <select> field.
Reporter

Comment 2

14 years ago
I would like the emphasise that this bug applies to all HTML elements that
supposed the 'disabled' attribute EXCEPT for disabled 'option' elements;
context-menu behaves as expected on them.
OS: Windows XP → All
Hardware: PC → All
Reporter

Comment 3

14 years ago
Added the working disabled <option> element to the example.
Attachment #186555 - Attachment is obsolete: true

Comment 4

14 years ago
Related to bug 253870 and Suite bug 141432?

Comment 5

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8b4) Gecko/20050906
Firefox/1.4 ID:2005090605

This behavior persists on the above nightly.  I am confirming this and moving it
to Core/Event Handling, with the caveat that a developer may not view this
behavior as a bug.
Assignee: nobody → events
Status: UNCONFIRMED → NEW
Component: Layout: Form Controls → Event Handling
Ever confirmed: true
QA Contact: layout.form-controls → ian
Assignee: events → nobody
QA Contact: ian → events

Comment 6

9 years ago
This seems to be a duplicate of
https://bugzilla.mozilla.org/show_bug.cgi?id=141432

Comment 7

8 years ago
(In reply to Adam from comment #6)
> This seems to be a duplicate of
> https://bugzilla.mozilla.org/show_bug.cgi?id=141432

Yes, yes it is.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 141432
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.