Find bar buttons lack hover feedback when using a dark lightweight theme

VERIFIED FIXED in Firefox 60

Status

()

defect
P2
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: newheulf, Assigned: bogdan)

Tracking

({regression})

57 Branch
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 unaffected, firefox57 wontfix, firefox58 wontfix, firefox59 wontfix, firefox60 verified, firefox61 verified)

Details

Attachments

(2 attachments)

Reporter

Description

2 years ago
Posted image Compare_Theme.png
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171102181127

Steps to reproduce:

- Install or preview a personas theme. (https://addons.mozilla.org/en-US/firefox/addon/just-black/)
- Open find toolbar (Ctrl + F)
- Play with "Highlight All", "Match Case" and "Whole Words" buttons.


Actual results:

These three buttons are displayed as plain text.


Expected results:

Different styles should be used to display whether the button is hovered over or selected. (As with the default style and old versions of firefox)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → Theme
Ever confirmed: true
Priority: -- → P2
Summary: Using personas theme break find toolbar buttons's animation → Find bar buttons lack hover feedback when using a dark lightweight theme

Comment 2

2 years ago
It's not only hover animation that is not working.  The indication that any of those buttons ("Highlight All", "Match Case" and "Whole Words") are selected is too minimal to be perceivable.  This is an accessibility issue.
Hey Mike, is there a student project looking at bugs like this?
Flags: needinfo?(mconley)
(In reply to Mike Taylor [:miketaylr] (58 Regression Engineering Owner) from comment #3)
> Hey Mike, is there a student project looking at bugs like this?

Yes, there is! jaws and I are mentoring them, and we've added this bug to the backlog.
Flags: needinfo?(mconley)
Thanks!
Assignee: nobody → bogdan
Comment hidden (mozreview-request)

Updated

a year ago
Attachment #8958652 - Flags: review?(ntim.bugs) → review?(dao+bmo)
Comment on attachment 8958652 [details]
Bug 1414693 - Find bar buttons lack hover feedback when using a dark lightweight theme

https://reviewboard.mozilla.org/r/227572/#review233562
Attachment #8958652 - Flags: review?(jaws) → review+

Updated

a year ago
Duplicate of this bug: 1447459

Comment 9

a year ago
I just spent hours struggling with this, as logged in bug https://bugzilla.mozilla.org/show_bug.cgi?id=1447459. 

I was using a dark theme - Black by MaDonna - which avoids visual interference when I use Tranquility to reverse text to white-on-black. (My vision is lousy!) I've now returned to the Default theme for testing. My issue is not about hover feedback - there is no hovering feedback when I'm using my Surface Book via touch. I see that there is hover feedback when using a mouse or pen and the Default theme. 

My issue is about feedback that the options are selected or not. With the dark theme there is no change at all, ever. With the Default theme, the option background turns darker when first selected, but only _very slightly_ darker than the hover highlight. When then un-selected via touch, the hover highlight remains from the touch, making it almost impossible to tell if you succeeded in turning the option off. Surprisingly, touching somewhere else does NOT remove this stuck hover highlight! Only moving a mouse (or pen in hover range) will turn off the highlight. 

There is hover feedback when using the Surface Pen. But like with touch, hover feedback sticks on if the pen is lifted rather than being slid sideways within hover range. 

But all that is trivial aesthetics compared to my confusion when there was no indication of options on or off! Maybe "dark lightweight themes" should come with a warning? Is there any way to totally reverse the interface outside the content window, like Tranquility can reverse the content? I only resorted to themes because it seemed the only way to hide all that white. And even then they don't reverse the main scrollbar - it remains white. 

Is there some way to identify themes that do not defeat this highlighting? "NON-lightweight"?

Sorry to seem picky, but when your vision gets bad enough that white-on-black enlarged text on a screen is the only way you can comfortably read, such little things matter a lot!

Comment 10

a year ago
mozreview-review
Comment on attachment 8958652 [details]
Bug 1414693 - Find bar buttons lack hover feedback when using a dark lightweight theme

https://reviewboard.mozilla.org/r/227572/#review236708

::: browser/themes/shared/toolbarbuttons.inc.css:47
(Diff revision 1)
>  }
>  
>  :root:-moz-lwtheme-brighttext,
>  toolbar[brighttext] {
> -  --toolbarbutton-hover-background: var(--lwt-toolbarbutton-hover-background, hsla(0,0%,100%,.2));
> -  --toolbarbutton-active-background: var(--lwt-toolbarbutton-active-background, hsla(0,0%,100%,.3));
> +  --toolbarbutton-hover-background: var(--lwt-toolbarbutton-hover-background, hsla(0,0%,70%,.4));
> +  --toolbarbutton-active-background: var(--lwt-toolbarbutton-active-background, hsla(0,0%,70%,.5));

As far as I can tell, the alpha value should be .6 to match the previous hover/active ratio and match the --toolbarbutton-active-background default.
Attachment #8958652 - Flags: review?(dao+bmo) → review+

Comment 11

a year ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d91b03764f78
Fix findbar buttons hover feedback when using a dark lightweight theme. r=jaws, dao

Comment 12

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d91b03764f78
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Please nominate this for Beta approval when you get a chance.
Flags: needinfo?(bogdan)
Comment hidden (mozreview-request)
Comment on attachment 8958652 [details]
Bug 1414693 - Find bar buttons lack hover feedback when using a dark lightweight theme

Approval Request Comment
[Feature/Bug causing the regression]:

Bug 1387762

[User impact if declined]:

Users with dark lightweight themes will not get visible feedback when hovering buttons in the Find bar

[Is this code covered by automated tests?]:

No.

[Has the fix been verified in Nightly?]:

No.

[Needs manual test from QE? If yes, steps to reproduce]: 

Yeah, it probably wouldn't hurt. STR are in comment 0.

[List of other uplifts needed for the feature/fix]:

None.

[Is the change risky?]:

No.

[Why is the change risky/not risky?]:

Theme tweak only.

[String changes made/needed]:

None.
Flags: needinfo?(bogdan)
Attachment #8958652 - Flags: review?(ntim.bugs) → approval-mozilla-beta?
Flags: qe-verify+
Comment on attachment 8958652 [details]
Bug 1414693 - Find bar buttons lack hover feedback when using a dark lightweight theme

css/theme fix, approved for 60.0b10
Attachment #8958652 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I reproduced this issue, based on the steps from comment 0, on Firefox 57.0 (20171106194249) under Windows 10 x64.
The issue is fixed on Firefox 60.0b10 (20180404171943) and Firefox 61.0a1 (2018-04-04) under Windows 10 x64, Ubuntu 16.04 x32 and macOS 10.13.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.