Turning off gfxscrollbars breaks text entry

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Johan Walles, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020412
Debian/0.9.9-6
BuildID:    0.9.9

If you add the following line to your prefs.js...

user_pref("nglayout.widget.gfxscrollbars", true);

... and then type an URL long enough to force the URL field to start scrolling,
GTK+ scroll bars will appear, hiding the text you are typing.

Changing the pref to "false" resolves the problem.


Reproducible: Always
Steps to Reproduce:
1. Add the following line to your prefs.js:

user_pref("nglayout.widget.gfxscrollbars", true);

2. Start Mozilla.
3. Type a *long* URL, so that the URL field has to start scrolling.


Actual Results:  The URL field is hidden behind two GTK+ scroll bars.

Expected Results:  The URL field should just have scrolled to the side.

Comment 1

16 years ago
I think bug 141976 and bug 141394 are dups of this.
May be older.

Comment 2

16 years ago
*** Bug 141976 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
the line pref("nglayout.widget.gfxscrollbars", true); seems to have been in
all.js since September 1999, so there should be no need to duplicate it in
prefs.js.. 

What happens if you remove the line alltogether? (Instead of setting it to false)
(Reporter)

Comment 4

16 years ago
If I remove the line, things work fine as well.

Comment 5

16 years ago
Snooped around in bug 35996:
I wonder if some of the explanation for this can be found in bug 35996 comment 20
Perhaps related:  bug 121440, where native scrollbar behaviour changed.
(March 31st this year)
reporter (Johan Walles): can you reproduce this bug with a recent build of
mozilla (for example, 1.1beta)? if so, please comment again with details. if
not, please resolve this bug as WORKSFORME. thanks.
no answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.