Investigate replacing most of the .eslintrc.js files in test directories with settings in the root .eslintrc.js file based on glob configuration

RESOLVED FIXED in Firefox 68

Status

enhancement
P2
normal
RESOLVED FIXED
2 years ago
3 months ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

(Blocks 1 bug)

3 Branch
mozilla68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

2 years ago
ESLint 4 has the capability to do glob-based configurations for files:

https://eslint.org/docs/user-guide/configuring#configuration-based-on-glob-patterns

We should see if we can make this apply to all our test directories where we're setting up environments.

Generally we should be able to pattern-match on "browser", "chrome", "unit" etc, but we might have to add some special cases :-(
Assignee

Comment 1

2 years ago
Oops, this is already bug 1379669.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1379669
Assignee

Comment 2

2 years ago
Not quite a duplicate of bug 1379669.

That bug is for configuration within directories, this is for applying to directories generally based on glob configurations.

As per the hidden discussion on that bug, this is currently blocked as ESLint doesn't support the "overrides" option within "extends", see https://github.com/eslint/eslint/issues/8813 for details.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [p5 due to being blocked]
Assignee

Updated

2 years ago
Status: REOPENED → NEW
Whiteboard: [p5 due to being blocked]
Assignee

Updated

2 years ago
Blocks: 1379669

Updated

Last year
Product: Testing → Firefox Build System
Version: Version 3 → 3 Branch
Assignee

Comment 3

4 months ago

A way of doing this came up in the ESLint issue, so I'm investigating it at the moment.

Assignee: nobody → standard8
Status: NEW → ASSIGNED
Assignee

Updated

3 months ago
Depends on: 1535708

Comment 6

3 months ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7d5929144262
Implement a central configuration for setting ESLint environments for test directories. r=mossop
https://hg.mozilla.org/integration/autoland/rev/2b85a797a7ca
Remove now unnecessary .eslintrc.js files or entries. r=mossop

Comment 7

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 2 years ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.